Introduction

Copyright © <Octobre 2014> by <François Proteau - JDC SA>. All Rights Reserved.


Principe de fonctionnement

Introduction ››

Lvclink_F permet aux magasins La Vie Claire franchisés de gérer leur fichier article par des mises à jour quotidiennes automatiques ou manuelles.

Les modifications et créations articles se répercutent du siège de La Vie Claire (LVC) dans les magasins.

Lvclink_F permet aussi de passer les commandes LVC par type d’article (normale, pain…), d’importer les factures LVC, de gérer les commandes et livraison des fournisseurs externes.

La gestion des avoirs, corrections de stock et budget sont aussi permises.

La mise à jour des articles se fait par échanges entre Lvclink_F et Lvcmaster_F. Ce dernier se trouve au siège et contient la liste des articles pour les magasins. Il gère aussi la liste des magasins franchisés avec leur code client, le % d’augmentation par rapport au tarif public.

Il existe deux augmentations possibles : une pour les articles à la marque LVC et une pour les autres marques.

Le magasin peut décider d’appliquer ces tarifs avec mise à jour automatique et quotidienne ou de choisir ses propres prix avec importation manuelle et conservation des prix magasins.

Le changement de prix de vente génère les étiquettes correspondantes.

Les prix publics seront malgré tout appliqués dans tous les cas aux catégories d’articles suivantes :

La librairie,

Les sans gluten

Les articles poids/prix étiquetés (prix fixe)

Les petits prix bio

Les tarifs de juillet et janvier seront mis à disposition 10 à 15 jours avant la date d’application et tiendront compte des types de tarifs appliqués dans les magasins.

Il sera ainsi possible aux magasins de vérifier les prix et de préparer les étiquettes à l’avance. L’application des nouveaux tarifs se fera automatiquement ou manuellement.

Tous les soirs le fichier article concernant les magasins est exporté par X3 et récupéré par LvcMaster_F qui importe ensuite les promotions.

Les magasins récupèrent la totalité des articles à chaque connexion ainsi que les promotions.

Les articles abandonnés définitivement par LVC sont cochés [image] dans LvcMaster_F au siège. L'information apparaît dans la fiche article de LvcLink_F [image] . Dans ce cas la fiche article n'est plus mise à jour.

Le mode PRIX LVC AUTO permet de fonctionner au prix LVC qui s'appliquent sur tous les articles sauf :

Les fruits et légumes,

Les articles avec une date de fin de blocage (après cette date, le PV revient au prix LVC)

Le mode PRIX MAG permet de fonctionner avec des prix de ventes spécifiques sauf sur :

La librairie,

Les sans gluten

Les articles poids/prix étiquetés (prix fixe)

Les petits prix bio

Les notions de PESABLE et la REMISE sur prix d'achat ne sont pas mises à jour et restent modifiables par le magasin.


Shéma de fonctionnement

Introduction ››


Changement de Structure

Introduction ››

Le logiciel est capable de changer automatiquement la structure de la BDD lorsqu'il détecte un changement dans la structure.

Cette conversion se fait uniquement sur le serveur qui est déterminé par son nom qui doit être 127.0.0.1.

Les postes élèves ne peuvent pas lancer la conversion et affichent un message indiquant la détection du changement de structure sans lancer le logiciel tant que la conversion n'a pas été faire par le serveur.

Ceci pour éviter les retour en arrière si tous les postes d'un magasin n'ont pas la même version.

Le passage en version qui intègre l'option éligible TR, lance la récupération de cette option depuis KeziaII avec le nota.

Motif Rupture articles abandonnés :

Ajout de 2 champs dans les fichiers article, histo et archive :

Motif_Rupture (250 caractères)

CodeArticle_Remplacement (13 caractères)

Changement de structure automatique sur le serveur au premier lancement.


Serveur de licence

Introduction ››

Romuald me signale que l'arrêt du serveur de licence ns363439.ovh.net va s'arrêter d'ici la fin de l'année 2024.

Romuald a créé l'adresse : licences.kezia2.fr quipointe actuellement sur ns363439.ovh.net et qu'il fera ensuite pointer sur le nouveau serveur une fois installé,

Il faudrait donc faire pointer LvcLink_F sur cette adresse au lieu de ns363439.ovh.net

Ok sur version 2.426


Démarrer

Copyright © <Octobre 2014> by <François Proteau - JDC SA>. All Rights Reserved.


Les mises à jour

Démarrer ››

Les mises à jour :

Tous les articles sont importés à chaque connexion ce qui évite des pertes d'informations.

Tous les articles sont importés sauf ceux cochés "PAS MAJ" dans la base de donnée de LvcMAster_F au siège de LVC.

Cela permet de gérer localement des articles LVC qui ne sont plus gérés par la centrale. Les modificaitons faites localement ne sont donc pas écrasées par la mise à jour. Exemple de la librairie.

Les promotions sont aussi importées lors de l'importation.

Le stock se met à jour au moment de la MAJ_STAT qui peut etre soit déclencher manuellement ou en Auto à la suite de la mise à jour des articles la nuit.Le stock est aussi mis à jour par toutes les opérations faites dans LvcLink_F (facture, avoir, mouvement de stock).

Deux modes de fonctionnement sont possibles : les magasins qui appliquent le tarif LVC (avec ou sans augmentation), ceux qui ne l’appliquent pas.

Dans le premier cas, la mise à jour sera automatique et journalière. Les prix de vente magasin et conseillé seront modifiés. Les majorations, si elles existent, s’appliqueront en dehors des petits prix bio, de la librairie, du sans gluten, des prix fixes, des articles à PV bloqués. Les étiquettes de changement de prix seront générées (voir le chapitre sur les étiquettes). Les promotions seront aussi importées.

Il existe 2 majorations possibles : une pour les produits à la marque LVC et une pour les autres articles.

Paramétrages :

Affichage :

Dans le second cas, la mise à jour sera manuelle et à la demande. Les prix de vente magasin (PVM) ne seront pas modifiés sinon par un verrou entre le PV et le PA. Les petits prix bio, la librairie, les prix fixes et le sans gluten sont systématiquement mis à jour. Le prix de vente conseillé (PVC) sera modifié.

Le nouveaux articles seront intégrés avec le tarif LVC.

Les modification de prix d'achat ou de vente sont archivées.

L'archive est visible par le menu OUTILS - HISTO CHGT PRIX.

La mémorisation des changements de prix des articles ne se fait pas dans le cas d'un calcul des promos dans la fenêtre "Modification prix articles" ni sur les changements dans la fenêtre fruits et légumes pour gagner en rapidité.

Paramétrages :

Affichage :

Dans tous les cas un tableau permet de voir les variations de prix d’achat et de vente et d’appliquer si besoin des modifications des PVM et de générer des étiquettes liées au changement de prix. Cette fenêtre n'affiche par les fruits et légumes.

Les étiquettes seront générées sur les articles en stock dans le cas de changement de prix de vente magasin (par répercuter ou une autre fonction).

Dans le cas d'articles LVC achetés à d'autres fournisseurs, l'article existant gardera son EAN et celui de LVC perdra le sien.

Depuis la version 1.640 l'information VENTE INTERDITE et REMISE sur PA ne sont plus récupérées. Ce sont des informations spécifiques aux magasins.

Quelque soit le mode de mise à jour, les articles suivant auront toujours le prix de vente mis à jour :

Librairie, Sans Gluten, Petis Prix Bio, Prix Fixe

Quelque soit le mode de mise à jour, les articles suivant n'auront jamais le prix de vente mis à jour : Fruits et légumes.

TVA : la mise à jour de la TVA peut être désactivée pour les magasins avec des taux différents (exemple de la Corse) par le menu PARAMETRES - CONFIGURER CONNEXIONS et avec l'option "Pas MAJ TVA".

Les articles doivent ensuite être exporté sur KeziaII :

La fenêtre "Fruits et légumes" n'exporte que les fruits et légumes à la validation.

La fenêtre "Vrac" n'exporte que le vrac à la validation.

Le bouton export des fenêtre "Base Articles", "Ecart de prix" et le menu "Export vers K2" exporte TOUS les articles.

Le bouton export accessible dans la fenêtre des réceptions LVC et des factures externe n'exporte QUE les articles de la facture sélectionnée.

Un fichier log mémorise les connexion à LVC et à KeziaII : LogConnexionLVC.txt :

Connexion K2 manuel articles sélectionnés 15/10/2021 à 17:10:40:96

Connexion K2 manuel articles sélectionnés 15/10/2021 à 17:11:41:48

Connexion K2 manuel articles sélectionnés 15/10/2021 à 17:18:39:36

Connexion LVC Manuel 21/10/2021 à 14:45:10:03

Connexion LVC Manuel 21/10/2021 à 14:55:50:66

Connexion K2 manuel articles sélectionnés 21/10/2021 à 15:07:45:06

Connexion K2 manuel articles sélectionnés 21/10/2021 à 15:31:16:69

Connexion LVC Manuel 21/10/2021 à 18:12:58:93

Connexion LVC Manuel 25/10/2021 à 14:34:27:21

Connexion LVC Manuel 25/10/2021 à 14:36:03:80

Connexion LVC Manuel 27/10/2021 à 10:30:24:92

Connexion K2 manuel articles sélectionnés 28/10/2021 à 17:14:23:13

Connexion LVC Automatique 29/10/2021 à 00:20:35:97

Connexion K2 Automatique tous les articles 29/10/2021 à 01:25:12:27

Connexion LVC Automatique 09/11/2021 à 00:20:36:86

Connexion K2 Automatique tous les articles 09/11/2021 à 01:24:35:24

Connexion LVC Automatique 02/12/2021 à 00:20:48:06

Connexion K2 Automatique tous les articles 02/12/2021 à 01:27:08:73

Connexion LVC Manuel 02/12/2021 à 18:05:46:35

Connexion LVC Automatique 11/01/2022 à 00:20:50:29

Connexion K2 Automatique tous les articles 11/01/2022 à 01:28:24:84


Les changements de tarif

Démarrer ››

Changement de tarif :

Deux fois par an, de nombreux articles changent de prix d’achat et de vente.

Ces changements seront récupérés lors des mises à jour manuelles ou automatiques 10 à 15 jours avant la date d’application.

Des étiquettes seront générées pour permettre la préparation de l’étiquetage (voir chapitre sur les étiquettes).

Dans le cas de la mise à jour LVC, l’application des tarifs se fera automatiquement durant le travail de nuit.

Les PVM seront modifiés en prenant en compte les majorations éventuelles.

Dans le cas des mises à jour manuelles le basculement se fera lors d’une remontée manuelle.

Les articles auront leur PA changé ainsi que le PVC. Le PVM sera modifié pour les articles avec le Verrou PR/PV dans le cas d’un changement de PA.


Lancement

Démarrer ››

L'icone suivante permet de lancer le logiciel :

Une gestion des utilisateurs est activée nécessitant l'identification de la personne qui utilise le logiciel :

Actuellement 2 utilisateurs sont possibles : Superviseur et Caisse.

Le Superviseur a accès à l'ensemble du logiciel, l'utilisateur Caisse est limité en particulier sur la gestion des articles.

Il est possible de faire démarrer le logiciel automatiquement pour un utilisateur en modifiant le raccourci.

Il faut alors passer en paramètres le login et le mot de passe sous la forme :

"C:\Program Files\LVCLink_F\LVCLink_F.exe" LOGIN MOT_DE_PASSE

Au démarrage le logiciel dépose sur une base de donnée centralisée le numéro de version utilisé ainsi que les paramètrage de mises à jour des articles :


Le menu général

Démarrer ››

Au lancement le logiciel indique dans une base de données centralisée chez JDC, le numéro de client, le numéro de version et la date de connexion.

Ces informations nous seront utiles pour vérifier les versions utilisées et intervenir si nécessaire en cas de mise à jour de programme non effectuée.

En effet une connexion par FTP est prévue chaque nuit pour mettre à jour les programmes, procédures et documents.


Le détail du menu

Démarrer ››

Tarif complet : mise à jour manuelle du tarif + mise à jour des ventes des 3 derniers mois.

Statistiques Ventes : Récupération des ventes des 3 derniers mois pour terminal portable.

Base article : liste des articles pour recherche, modification, création, suppression et export.

Fruits & légumes : liste des F/L pour activation/désactivation (apparaît ou pas sur le clavier tactile de la caisse), pesable ou pas et changement de prix.

Vrac : liste des articles vracs pour pesable ou pas et activation/désactivation (apparaît ou pas sur le clavier tactile de la caisse).

Ecart Prix : affiche la liste des articles ayant changé de prix (achat et vente) lors de la dernière importation. Cette liste s’affiche automatiquement lors d’un import manuel.

Modif PV : fenêtre pour modifier rapidement les PVM et PA en fonction d’un coefficient et sur une sélection d’articles.

Etiquettes : pour imprimer des petites ou grandes étiquettes, en ajouter (manuellement ou avec le terminal de saisie) et purger la liste.

Export vers K2 : exporte les articles dans KeziaII pour mettre sa base article à jour.

Contrôle des prix : comparaison des prix entre le fichier et la saisie avec un Scanpal

Export Tarif Scanpal : envoie des articles avec les ventes des 3 dernières semaines.

Etat Articles Prix Bloqués : liste les articles à prix bloqués avec les ventes des 3 derniers mois.

Liste fournisseurs : liste des fournisseurs avec ajout, modification, suppression possible.

Nouvelle LVC : création d’une commande pour LVC avec impression et envoie par SFTP. Les mails sont aussi possibles.

Histo LVC : liste des commandes déjà créées et rappel d’une commande non terminée. Impression et suppression sont possibles.

Nouvelle Externe : création d’une commande d’un autre fournisseur avec impression et envoie par mail.

Histo Externe : liste des commandes déjà créées pour les autres fournisseurs et rappel d’une commande non terminée. Permet de transformer une commande en bon de livraison/facture. Impression et suppression sont possibles.

Enregistrement LVC : importation facture LVC au format « sih_xxxx.txt » avec xxxx = numéro client LVC.

Histo Receptions Externes : liste des bons de livraison/factures des autres fournisseurs. Impression, correction et suppression sont possibles.

Nouvel avoir LVC : création d’un avoir pour LVC avec impression et envoie par mail.

Histo Avoir LVC : liste des avoirs déjà créés avec impression, correction et suppression possibles.

Nouvel Avoir Externe : pour les autres fournisseurs

Histo Avoir Externe : liste des avoirs des autres fournisseurs. Impression, correction et suppression sont possibles.

Création des Objectifs : liste d’objectif en CA à atteindre par jour sur une période.

Analyse Objectifs : compare sur une période le CA prévu avec le CA réalisé avec commentaire possible (neige, pluie, grève….).

Saisie : permet de noter les gratuités.

Histo : liste des gratuités déjà saisies avec impression et suppression posibles.

Histo cumul : cumul des gratuités sur une période avec impression

Entrées : saisies des corrections de stock en positif avec motifs.

Sorties : saisies des corrections de stock en négatif avec motifs.

Histo : cumul des entrées ou sorties sur une période.

Permet l’importation des articles dans un format donné pour ajout d’articles de Kwisatz.

Configurer connexions : paramétrage des connexions Lvcmaster, LvcLink, KeziaII.

Configurer l’imprimante : choix de l’imprimante par défaut.

Choix Terminal : type de terminal de saisie, port com, vitesse.

Configurer Douchette : type de douchette, port com, vitesse.

Configurer Documents : site, numéro client, nom du magasin , entête et pied des documents.

Entête Documents : entête et pied des documents.

Ré indexation des fichiers : maintenance des index.

Purge EAN orphelins : enlève les codes barre sans articles

Sauvegarde : paramétrage et sauvegarde de la base de données.

Archive : liste des articles archivés. VERIFIER AVEC FX

Programme SCANPAL : envoie du programme par défaut dans le terminal de saisie.

Purge : effacement des documents (commande, livraison, avoirs…) jusqu’à une date limite.

Outils

Test Connexion : vérifie la bonne connexion avec le siège.

Recalcul identifiant : maintenance des entêtes de fichier de la base de données.

Reindex : maintenance des index de fichiers.

SQL : pour saisir des requêtes SQL

Maj Prix Prev : pour déclencher manuellement la mise à jour des prix prévisionnels.

Ajout Gencod : pour ajouter des EAN sur des codes existants


Les articles

Le menu Articles – Base article affiche la liste des produits de la base.

Des sélections sur le rayon, la famille, la sous-famille, le fournisseur, la marque (fabricant), les nouveaux produits, les petits prix bio, les articles abandonnés (achat interdit), les articles à prix bloqué, les prix de vente prévisionnel (avec la date d’application) sont possibles.

Le bouton [image] réinitialise la liste en annulant les sélections

La recherche d’un article en fonction du code, de la référence fournisseur, du libellé (partielle ou complète), du code barre est possible.

Le bouton [image] affiche à nouveau tous les articles.

La colonne « Select » associée avec les boutons suivants

permet de référencer les articles suivis en magasin pour une recherche plus rapide.

Le « double-clic » sur un article ou le bouton [image] permet d’ouvrir la fiche article pour consultation ou modification.

Le bouton [image] crée une nouvelle fiche article à remplir. C’est nécessaire pour les articles autres que LVC.

Le bouton [image] supprime les fiches articles avec une coche dans la colonne « Select ». Ces effacements ne sont pas reportés dans KeziaII car il n’est pas possible d’enlever des articles utilisés.

Le bouton [image] affiche une liste de document pour imprimer des listings articles.

Le bouton [image] ajoute le ou les articles sélectionnés (touche CTRL ou Shift) dans les étiquettes avec le PV correspondant au sélecteur choisi.

Le bouton [image] lance l’exportation des articles dans KeziaII.

permet la sortie de cette liste.


La liste des articles

Les articles ››

Permet d'accèder à la liste des articles :

Les zones RAYON / FAMILLE / SSFAM / FOURNISSEUR / MARQUE permettent de visualiser les articles correspondants.

La liste des fournisseurs et des marques acceptent une recherche alphabétique (la frappe d'une lettre positionne sur la ligne qui commence par cette lettre).

Le bouton [image] réinitialise la recherche

Les filtres [image] permettent de visualiser les articles correspondants.

Les options suivantes ont un fonctionnement identiques :

Le bouton [image] réinitialise la recherche.

Les boutons [image] sélectionnent ou désélectionnent les articles. Il est aussi possible de le faire manuellement en cochant les cases dans la colonne "Select" ou en cliquant sur le bouton [image] après avoir sélectionné la ligne.

Ces articles cochés peuvent ensuite être [image] référencés ou déréférencés.

Des codes couleurs existent dont la signification est la suivante :

Désignation Vert clair = article référencé (suivi par le magasin) avec stock

Désignation Rouge = article référencé sans stock

Select rouge = pas de code barre

Désignation magenta = blocage vente.

Ligne jaune = article nouveaux pendant 30 jours après leur date de création.

Les articles cochés peuvent aussi servir à générer des étiquettes par le bouton [image] .

Les options associées [image] déterminent le type de tarif imprimé sur ces étiquettes.

Le bouton [image] crée une nouvelle fiche article. Dans ce cas le code commencera automatiquement par X avec une numérotation automatique.Le code peut être modifié par le X sera permanent. L'idart est sur la numérotation en 50 000 000.

Le logiciel propose un code en fonction des articles existant dans le fichier article et archive.

La TVA se remplie automatiquement par la TVA à 5.5%. Penser à la changer si la TVA est différente.

Le bouton [image] modifie l'article surligné (un double clic permet aussi d'afficher l'article).

Les modification de prix d'achat ou de vente sont archivées.

L'archive est visible par le menu OUTILS - HISTO CHGT PRIX.

Le bouton [image] donne un listing des articles listés à l'écran. 3 documents sont disponibles :

ETAT_Infos_art imprime les informations suivantes :

ETAT_Liste_PV_art imprime les informations suivantes :

ETAT_Liste_PVPrev_art imprime les informations de tarif à date

Le bouton [image] permet d'exporter vers KeziaII.

Le logiciel demande confirmation :

et demande ensuite si l'export doit se limiter aux articles sélectionnés ou à tous les articles :

OUI : envoie que les articles sélectionnés

NON : envoie tous les articles

ANNULER : annule l'opération

Dans le cas de l'envoie des articles sélectionnés, le logiciel demande à la fin si il doit déselectionner les fiches :

L'envoie vers KeziaII des articles active les triggers de gestion des multi-tarif dans KeziaII.

Le bas de l'écran présente un filtre sur les colonnes coefficient, taux de marge et taux de marque.

La saisie d'une requête (en sélection uniquement) est possible :

Les requêtes sont mémorisées et la saisie affiche la liste des précédentes avec possibilité d'en choisir une dans la liste :

Le bouton [image] ferme cette fenêtre.

Gestion Q_mini et Q_maxi pour le calcul du réappro :

Le bouton [image] ouvre une fenêtre qui permet de définir rapidement le Q_mini et Q_maxi par article afin de gérer au mieux le calcul de réappro :

Les combos de sélection Rayon, Famille, Sous-famille, Fournisseur, Marque permettent de sélectionner les articles en fonction de ces critères.

Le bouton [image] permet de remettre à zéro la sélection.

Il est nécessaire de définir une période (nombre de jours depuis la date du jour) et cliquer sur Go pour afficher la liste des articles sélectionner avec le nombre d'achats, de ventes et de pertes sur la période.

La petite fenêtre affiche la progression du calcul :

A la fin du calcul le message suivant apparaît :

Il est ensuite possible de saisir en ligne les Q_mini et Q_maxi en fonction des informations affichées :

Le bouton [image] enregistre les modifications saisies :

Le message suivant apparaît :

Il ensuite possible de continuer la saisie ou de quitter

Le bouton [image] ferme cette fenêtre après validation du message :

Si l'enregistrement n'a pas été fait, les données saisies seront perdues.


La fiche article

Les articles ››

L’article à un identifiant unique (Idart) géré par le logiciel. Le code (référence fournisseur LVC) est aussi unique pour permettre le lien entre X3 (logiciel LVC) et les magasins. Pour des articles créés directement il prendra la forme X123456. Le X se mettra automatiquement afin de s’assurer qu’un article n’est pas le même code qu’un article LVC. Un code automatique sera proposé. Il peut-être modifié.

Le code automatique prend un numéro libre en tenant compte des numéros existants dans le fichier article (qui contient les articles actifs) et dans le fichier archive (qui contient les articles effacés).

La nomenclature des articles (rayon, famille, sous famille, marque, TVA) est définie par LVC.

Le fournisseur 99 est La Vie Claire.

Les autres fournisseurs seront gérés dans le menu Articles – Fournisseurs.

A la création d'une fiche article, la TVA se remplie automatiquement par la TVA à 5.5%. Penser à la changer si la TVA est différente.

Les différentes informations :

Si cochée indique que l'article n'est plus suivi par LVC. La fiche article ne sera plus mise à jour.

Normalement prévue pour être définie par LVC, elle peut aussi être cochée par le magasin pour rendre un article non modifiable.

Abandon : l’achat n’est pas possible donc pas de commande.

Vente bloquée : l’article ne peut pas être vendu.

Gestion stock : est cochée par défaut. Le stock de l’article se mettra à jour en fonction des mouvements. Si décoché le stock ne varie plus.

Pesable : active ou désactive la pesée avec balance. La mise à jour des produits renseigne cette valeur dans le cas d'une création mais pas d'une modification.

Cette valeur est à gérer par le magasin en interne.

Verrou PR/PV : répercute les variations du PA sur le PVM. Inutile sur les articles LVC dans le cas d’une mise à jour automatique.

Dans le cas de la gestion PRIX MAG, le PVM sera modifié automatiquement lors de la variation du prix d'achat soit lors de la remontée des articles soit par importation des factures LVC soit par modification du prix d'achat dans une facture externe.

BIO : petit prix bio ou petit prix des marques en distribution.

PA BRUT : PA pour le mini détail = réappro. mini. Dans le cas de multifournisseur, cette valeur sera égale au dernier prix d'achat de l'article. En effet la saisie d'une facture entraîne la mise à jour du PA lié au fournisseur ainsi que le PA BRUT.

PA PCB : PA pour le PCB.

PCB Max : Si coché alors le logiciel résonne sur le PA PCB en tant que prix d'achat.

Dans le cas d'une gestion en PCB MAX, le prix de revient tient compte du PA PCB, donc le coefficient se calcule d'après ce prix d'achat.

Si le Verrou PR/PV est coché, le calcul du prix de vente se fera donc en fonction de l'évolution du PA PCB et non du PA BRUT.

Remise : remise sur le PA Brut

Remise Bloquée : Si cochée la mise à jour des articles ne change pas la valeur de la remise sur le PA Brut.

Depuis la 1.640 la remise sur PA n'est plus importée lors du transfert depuis Lvcmaster_F.

Cette donnée est donc spécifique au magasin. L'option reste mais n'a plus d'effet.

Depuis la version 1.632, la remise n'est plus importée. La valeur reste donc locale quelque soit le paramétrage de cette option.

FRAIS Tx : frais en pourcentage du prix d’achat

FRAIS € : frais en montant

Il n’est possible de saisir que l’un ou l’autre.

P. REVIENT : PA BRUT ou PA PCB – la remise + les frais

Coeff. = PV TTC / Prix de revient HT

Tx de marque = (PV HT - PR HT) / PV HT

Pas de remise : article sur lesquels la remise est interdite. Les livres et sans gluten entrent dans ce cadre.

Pas de fidélité : le calcul de la fidélité est désactivé. . Les livres et sans gluten entrent dans ce cadre.

EDI interdit : l’envoie par EDI n’est pas possible.

Sommeil : Si cochée, l'article est en sommeil. Pour les fruits et légumes et le vrac cela correspond au fait de décocher l'option ACTIF. Dans KeziaII, il n'apparaitra donc pas dans les listes avec sélection ni dans les touches du clavier tactile si l'option de cacher les articles en sommeil est activée.

Pesable : s’utilise avec une balance connectée. La saisie de l’article envoie le PVM à la balance et reçoit le poids avec le prix à payer de la balance.

CD : code Crossdock

PV TTC : prix de vente TTC du magasin

PVC : prix de vente TTC au tarif LVC. Cette zone n'est visible que pour le fournisseur La Vie Claire et pas dans avec un autre fournisseur.

Prix Fixe : est utilisé par LVC pour indiquer les articles poids/prix avec étiquettes et pour lesquels il faut donc respecter le prix de LVC. Le PVC est donc appliqué dans tous les cas et ne tient pas compte des pourcentages d’augmentation éventuels.

PV bloqué : le PV TTC n’est pas modifié tant que la « Date Fin Blocage » n’est pas atteinte.

Permet de définir un prix spécifique, différent du tarif LVC , dans le cadre d’une mise à jour automatique.

PV Prev. : prix prévisionnel.

Date application : date application du prix prévisionnel.

PA Promo : prix d'achat en promo.

PV Promo : prix de vente promo.

Debut Promo : date de début de promo

Fin Promo : date de fin de promo

L'information de promotion est récupérée lors de la mise à jour des articles LVC. Un article Hors LVC et LVC peut avoir une promotion.

Dans le cas des articles LVC la promotion sera écrasée par la mise à jour si une promo LVC active exist. Sinon l'article garde sa promotion.

Création : date de création de la fiche.

Ccompte Ach. : compte comptable achat pour l'export en comptabilité.

Ccompte Vente : compte comptable vente pour l'export en comptabilité.

Origine : origine du produit. information utilisée dans les étiquettes vrac.

Organisme certificateur : organisme certificateur du produit. Information utilisée dans les étiquettes vrac.

Q Mini : stock minimun

Q Maxi : stock maximum

La liste des EAN permet d’avoir plusieurs codes barre (numériques ou alphanumériques) pour le même article avec éventuellement des conditionnements de vente supérieurs à un. Exemple de la bouteille d’eau avec un EAN pour la bouteille donc conditionnement à 1 et un EAN pour le pack de 6 avec un conditionnement de 6. L’utilisation de l’EAN du pack vendra la bouteille avec une quantité de 6 et celui de la bouteille ne vendra qu’un article.

Par défaut le conditionnement se renseigne à 1.

La zone [image] permet de choisir un arrondi automatique sur le prix de vente de l'article.

Les choix sont :

Consigne : permet de déclarer l'article comme une consigne avec une valeur en prix de vente. Cette article consigne sera ensuite associé avec l'article à vendre dans KeziaII.

MAJ : date de mise à jour ou de modification.

Pts Fidel : le nombre de points fidélité associé à l'article. Utilisable dans le cas d'une fidélité en points.

Coef Fidel : permet de calculer le nombre de point fidélité en fonction du prix de vente.

La modification du PV (manuellement, par import et recalcul) entraîne le recalcul des points de fidélité.

Si le coefficient est égal à zéro alors le nombre de points est modifiable manuellement.

L'option [image] permet de définir par exemple que si 4 articles sont vendus, 1 sera offert donc 3 payés.

Colisage : permet de gérer les cas particuliers des articles vendus par LVC au colis alors que l'article est vendu à l'unité ou au kilo.

Lors del'importation de la facture si le colisage est > 1, la quantité de facturation sera multiplié par le colisage pour mettre à jour le stock (la quantité de la facture ne sera pas changée) et le PA de la fiche article sera mis à jour en divisant le PA facturé par le colisage.

Exemple : pommes de terre facture 1 x 10 donnera 10 en stock et 1 en PA.

Dern. Vente : indique la date de la dernière vente.

CA Total : CA TTC réalisé par les ventes de cet article.

Ces 2 dernières options sont mises à jour par le calcul des statistiques qui est programmable la nuit et qui peut se lancer manuellement par le menu :

Nota : permet de saisir un nota qui correspond au Nota de la fiche article de KeziaII

Eligible TR : pour les articles qui sont éligibles aux tickets restaurants. L'information est récupérée de LvcMaster_F uniquement si l'option de connexion à un base KeziaII V10 est active.

Ces 2 options sont récupérées de KeziaII lors du changement de version et après la restructuration de la BDD.

Motif Rupture : contient le motif de rupture pour les articles abandonnés. Utilisé lors des commandes LVC.

Code de remplacement : contient le code article de remplacement pour les articles abandonnés. Utilisé lors des commandes LVC.

Ces 2 zones sont en lecture seule et sont alimentées par l'importation des articles depuis LvcMaster_F (lui même alimenté par X3).

Le bouton [image] efface l’EAN sélectionné dans la liste et archive la fiche article dans l'archive.

L’onglet nomenclature permet de visualiser une composition faite par LVC. La vente de cet article déstocke les composants de la nomenclature.

Les nomenclautures des articles LVC ne sont pas modifiables.

Il est possible de créer des nomenclatures sur des articles créés par le magasin donc des produits de fournisseurs externes. Dans ce cas la quantité accepte 3 décimales.

L'onglet Fournisseur permet de saisir plusieurs fournisseurs pour le même article.

Le rang du fournisseur est enregistré et envoyé à KeziaII. Rang 0 pour le fournisseur de la fiche article et Rang 1 pour les autres fournisseurs.

La saisie du fournisseur dans la fiche article entrainera la recopie des informations dans l'onglet fournisseur à la validation de la saisie.

Les modifications sont de même reportées.

Si un article LVC a un autre fournisseur, la mise a jour des articles conservera cette information.

Il est possible de définir un fournisseur de la liste en fournisseur principal par le bouton [image] . Dans ce cas les informations liées à ce fournisseur sont recopiées dans la partie principale de la fiche article.

Dans le cas d'un article LVC, il est nécessaire de cocher PAS MAJ pour garder le founisseur externe en principal malgré la mise à jour des articles.

Le PA sera mis a jour dans l'onglet fournisseur (dans le fichier fournisseur_article) malgré tout ce qui permet de connaitre l'évolution du PA.

Le bouton [image] EN BAS A DROITE de la fenêtre fournisseur permet d'effacer un des fournisseurs.

L'onglet Tarifs permet de gérer 4 PV supplémentaires dans le cadre du mode pilote.

Ces PV peuvent être libre ou copier à partir du PV. Dans ce dernier cas la case suivante (une par PV supplémentaire) doit être cochée :

Le bouton [image] génère une étiquette au prix normal pour l'article.

Le bouton [image] génère une étiquette au prix promo pour l'article.

Le bouton [image] ferme la fiche article en enregistrant les modifications.

Le bouton [image] crée un nouvelle fiche à partir de celle affichée mais en supprimant les codes EAN de l'article d'origine et le code est de la forme X0000001. Le logiciel propose un code en fonction des articles existant dans le fichier article et archive. Une étiquette est générée pour le nouvel article.

Le bouton [image] ferme la fiche article sans enregistrer les modifications.

Le bouton [image] efface l’article. L’effacement n’est pas reporté dans KeziaII. L'article est conservé dans un fichier d'archive.

Les informations de code barre sont effacées définitivement.

Les informations de fournisseur (fichier fournisseur_article) sont conservées.

Le menu OUTILS - CORRECTIF - ARCHIVE permet de restaurer un article effacé. Les données des EAN seront à resaisir.

Le bouton [image] imprime une fiche article qui reprend les informations principales de l’article en cours.

Le bouton [image] permet de visualiser l'historique des réceptions de l'article.

Le bouton [image] permet de visualiser l'historique des commandes de l'article.

Il est possible d'ajouter des enregistrements dans les rayons, familles, sous familles et marques (fabricant) par le menu OUTILS - AJOUT RFS.

Statistiques immédiates :

Le bandeau permet d'obtenir les quantités de vente, d'achat et de perte sur les X derniers jours.


Les fruits et légumes

Les articles ››

Le menu Articles – Fruits et Légumes (FL) permet d’afficher une liste d’articles qui appartiennent uniquement au rayon 3 – FL.

Les tris sont possibles sur les colonnes avec une double flèche dans l’entête de la colonne.

Les recherches sont possibles sur les colonnes avec une loupe dans l’entête de la colonne.

Le PA Brut avec la Remise sont affiché avec le prix de revient. Le calcul du PV à partir du coefficient se fait à partir du PR, le calcul du prix coûtant se fait à partir du PA Brut.

La colonne « Pesable » permet de déterminer les FL pesables ou non.

La colonne « Actif » permet d’activer ou désactiver les articles. Les « actifs » apparaissent sur le clavier tactile de KeziaII, les autres non.

La colonne « Nouv. PV » permet de saisir les prix de vente des FL.

Les modifications sont envoyés à KeziaII par le bouton

La colonne «Coef N. PV» permet de saisir un coefficient qui calculera le PV correspondant.

Les prix de vente peuvent agir immédiatement ou à une date donnée. Dans ce cas il faut cocher l’option PV Prev avec la date prévue (en général le lendemain). Le bouton de validation enregistre les modifications dans envoyer les articles à KeziaII.

Il faudra entrer dans cette fenêtre le lendemain et valider (en cochant PV Direct) pour envoyer à KeziaII les nouveaux prix dans le cas d’une mise à jour LVC manuelle sinon l’information sera envoyée automatiquement la nuit (seulement si PV LVC AUTO).

Le bouton [image] ferme la fenêtre et annule les modifications.

La zone [image] permet d'alimenter la colonne "Nouv. PV" par un calcul sur le prix de revient et un coefficient.

Si l'option HT est cochée le calcul sera le suivant : PV TTC = (PR x coefficient) + TVA sinon le calcul sera : PV TTC = PR x coefficient.

ATTENTION : le coefficient affiché dans la liste dépend aussi de cette option.

Le bouton [image] recopie le prix de vente conseillé dans la colonne "Nouv. PV".

La case à cocher [image] permet d'agir sur le Nouv. PV en modifiant le prix de revient (P. revient). Dans ce cas le coefficient reste fixe et le Nouv. PV est mis à jour par la formul PR * coefficient de la fiche article = Nouv PV TTC.

Le bouton [image] donne la possibilité de créer des prix promo sur une période avec un calcul sur le PA Brut et un coefficient (obligatoirement différent de zéro). Les articles déjà en promotion sur la même période ne seront pas modifiés.

La fenêtre suivante s'ouvre :

Date début = date de début de la promotion (le vendredi compris par exemple)

Date fin = date de fin de promo (le samedi compris par exemple)

Coefficient = valeur avec l'option HT - TTC à choisir

Si l'option HT est cochée le calcul sera le suivant : PV TTC = (PA x coefficient) + TVA sinon le calcul sera : PV TTC = PA x coefficient.

Calcul réalisé suivant l'option BRUT - NET

Le choix BRUT entraîne un calcul sur le prix d'achat brut (avant remise), le choix NET calcule sur le prix d'achat net (après remise).

Si l'option "Articles sélectionnés seulement" est cochée, le calcul se fera uniquement sur les lignes cochées.

Il est ensuite possible de voir les PV PROMO avec leur date d’application :

Les sélecteurs suivants

permettent de filtrer la liste des fruits et légumes et d'agir dessus en particulier pour le calcul des prix coûtants.

Le calcul des prix coutants écrit directement dans la fiche article. Par contre la saisie manuelle des promotions dans la fenêtre s'enregistre à la validation.

Le bouton [image] permet de remettre à zéro les filtres.

Le bouton [image] remet à zéro la saisie des promotions (prix, date de début et de fin). Il est nécessaire de valider la fenêtre pour l'enregistrement puis de revenir dans cette fenêtre pour refaire (ou pas) les promotions.

L'option

Si l'option n'est pas cochée : si la date du jour est comprise dans la promotion en cours, le nouveau calcul n'écrase pas les données déjà présente, sinon la mise à jour se fait.

Si l'option est cochée :si la date de fin de promo de l'article est supérieure à la date de début de promo saisie alors pas de remplacement, sinon la mise à jour se fait.

Le bouton [image] permet de visualiser seulement la fiche article à partir de la ligne sélectionnée. La modification n'est pas acceptée dans ce cas. Les modifications acceptées se font dans la liste.

Le bouton [image] permet de créer un article depuis la fenêtre.

Le bouton [image] enregistre les modifications et envoie les articles dans KeziaII.

Le bouton [image] permet de générer des étiquettes avec choix du prix (PVM ou Promo) pour les FL actifs :

Les étiquettes sont générées pour les lignes cochées.

Les boutons [image] permet de tout sélectionner ou tout désélectionner.

Le choix [image] permet de générer des étiquettes dans la liste des étiquettes pour l'option "Normale".

L'option "Grande" génère une liste de grandes étiquettes au même format que le vrac :

ATTENTION : ces étiquettes seront générées soit pour tous les articles

soit pour les fruits et légumes actifs

Les options [image] permettent aussi de visualiser dans la liste soit tous les fruits et légumes soit ceux qui sont actifs.

Le bouton [image] donne une liste de documents possibles.

Ces états sont modifiables avec Etats et Requête depuis la 2.412

ETAT_FruitsLegumes liste tous les fruits et légumes avec les informations suivantes :

ETAT_FruitsLegumes donne les mêmes informations uniquement sur les articles actifs.

ETAT_FruitsLegumes_promo donne les informations avec les dates et prix promos pour les fruits et légumes actifs :

ETAT_FruitsLegumes_ChgmtPrix liste les produits avec le Nouv. Nouv. PV différent de PVM (hors PV *Nouv. à zéro) A faire avant de valider pour avoir les changements de prix :


Le vrac

Les articles ››

Le menu Articles – Vrac permet d’afficher une liste d’articles qui appartiennent uniquement à la famille 53 – Produits en vrac.

Elle permet de rendre actif ou pas les articles et donc de les faire apparaître ou pas sur le clavier tactile de KeziaII.

L'option Pese permet de rendre pesable ou pas un article.

Le bouton [image] coche l'option de sélection sur tous les articles de la liste.

Le bouton [image] désélectionne tous les articles de la liste.

Le bouton [image] n'affiche que les lignes séelctionnées.

Le bouton [image] permet d'afficher la fiche article en lecture et modification qui ne sera pas répercutée dans la liste des articles du vrac immédiatement.

Le bouton [image] enregistre les modifications et envoie ces articles dans KeziaII.

Le bouton [image] n’enregistre pas les modifications et n’envoie pas le vrac dans KeziaII.

Le bouton [image] imprime la liste du vrac en entier ou que les articles actifs.

Les boutons [image] permettent d’agir rapidement sur la sélection des lignes.

Seuls les articles sélectionnés sont exportés sur KII lors de la validation.

Le bouton [image] imprime des étiquettes spécifiques vrac pour les articles sélectionnés (avec une coche dans la colonne « Selec »).


Vérification des prix

Les articles ››

Le menu Articles – Ecarts de prix affiche la fenêtre suivante :

Elle compare les prix avant mise à jour avec les prix après la mise à jour. Il ne faut donc pas lancer un nouvel import avant d’avoir vérifier ces informations. Ceci est valable pour les magasins qui n’utilise pas le tarif LVC. Mais ces dernier peuvent malgré tout allez vérifier les évolutions de prix dans cette fenêtre. Cette fenêtre n'affiche par les fruits et légumes.

Les articles sont aussi sélectionnés d'après la date de mise à jour (MAJ_SEG) qui se stocke dans le fichier PARAMETRE.FIC.

Pour les magasins qui font la mise à jour manuellement, cette fenêtre s'ouvre automatiquement à la fin de la réception des articles.

Pour les articles en Verrou PR/PV, le prix de vente aura été modifié pour garder le coefficient fixe. Le calcul ne tient pas compte de la troisième décimale.

Dans le cas d'une gestion en PCB MAX, le prix de revient tient compte du PA PCB, donc le coefficient se calcule d'après ce prix d'achat.

Pour les articles en PCB MAX, les valeurs des colonnes PA et PA Anc. contiennent le PA PCB, sinon elles contiennent le PA Brut.

Les options :

Sélectionnent dans la liste les articles répondant au choix.

L’option « Art. Référencés » n’affiche que les articles qui ont été cochés Référencés.

L’option « Uniq. Modif Prix » affiche les articles dont soi le PA soit le PV ont été modifiés.

L'option [image] n'affiche que les articles en stock.

Sur cette liste il est ensuite possible d’effectuer des modifications manuelles en double-cliquant sur la ligne ou le bouton [image] .

Le bouton [image] permet aussi d'accéder à la fiche article de la ligne sélectionnée (en surbrillance) pour visualisation ou modification.

Il est aussi possible d’appliquer des modifications par lot :

Le bouton [image] copie le prix de vente conseillé en prix de vente magasin sur les articles sélectionnés (cocher dans la colonne « Selec ») hors articles prix bloqué et avec Verrou Pr/PV.

Le bouton [image] répercute la variation de prix d’achat sur le prix de vente pour les articles sélectionnés.

Il faut pour cela cocher les lignes dans la colonne "Select". Ces lignes seront automatiquement déselectionnées lors de l'export des informations vers KeziaII.

Il est possible d’utiliser les boutons [image] pour des sélections – déselections plus rapides.

Les boutons [image] permettent de référencer ou pas des articles pour une meilleure visibilité.

Le bouton [image] exporte les articles dans KeziaII pour mettre à jour sa base article.

Le bouton [image] imprime une liste d’articles.

Le bouton [image] ajoute les articles sélectionnés dans les étiquettes.

Les étiquettes seront générées automatiquement sur les articles en stock dans le cas de changement de prix de vente magasin (par répercuter ou une autre fonction).

Le bouton [image] ferme la fenêtre.


Modification des prix

Les articles ››

La modification des prix :

Le menu Articles – Modif PV affiche la fenêtre suivante :

Les colonnes avec [image] sont triables.

Les zones de sélection RAYON – FAMILLE –SS FAM – FOURNISSEUR – MARQUE permettent de n’afficher que les articles voulus.

Le bouton [image] annule la sélection.

La zone recherche permet de trouver un article selon son code, sa référence fournisseur, un EAN, son libellé.

Le bouton [image] annule la recherche.

Il est ensuite possible d’appliquer [image] à la liste des articles une augmentation de :

PA BRUT : par la formule ancien PA BRUT multiplié par un coefficient.

Si l'option HT est cochée le calcul sera le suivant : PV TTC = (PA x coefficient) + TVA sinon le calcul sera : PV TTC = PA x coefficient.

Il est aussi possible d’ajouter une valeur. Dans ce cas le coefficient doit être à 1.

Si le coefficient est différent de 1 la valeur sera ajoutée au résultat de l’opération.

Si le coefficient est 0, les prix de vente seront remplacés par la valeur

PVM : le calcul est le même que précédemment mais avec en base de calcul soit le PVM (exemple d’une augmentation de 10% : PVM x 1.1 + 0), soit le PA BRUT (PVM = PA BRUT x 2.5 + 0).

L'option [image] permet d'imprimer soit les étiquettes pour les articles en stock, soit pour tous les articles.

Les modifications des prix de vente ne s'appliqueront pas sur les petits prix bio, les prix fixes, les prix bloqués, la librairie et le sans gluten.

Il est aussi possible de définir des promotions sur les articles sélectionnés.

Début Promo = date de début de la promotion (jour compris)

Fin Promo = date de fin de la promotion (jour compris)

Le calcul sera PV actuel x Coefficient (0.90 pour 10 % en moins) + une valeur éventuelle.

Les petits prix bio sont exclus de ce calcul.

Le bouton [image] lance le calcul et alimente la table à l'écran.

Le bouton [image] remet à zéro les promotions des articles sélectionnés.

Le bouton [image] permet de vider le contenu d'un terminal portable pour remplir la fenêtre et agir sur les prix des articles récupérés.

Un clic droit sur le bouton [image] d'afficher l'option "Historique" qui donne accès aux anciens fichiers générés par le vidage du terminal portable. Cela permet de récupérer à nouveau leur contenu.

Le bouton [image] recopie le PVC dans le PVM pour les articles de la fenêtre.

Le bouton [image] permet de modifier ou visualiser la fiche article en surbrillance.

Le bouton [image] permet de créer un nouvel article.

Le bouton [image] permet de valider la modification des prix et de quitter la fenêtre après avoir répondu au message suivant :

Si OUI enregistre les prix dans les articles et quitte la fenêtre.

Si NON n'enregistre pas les prix dans les articles et quitte la fenêtre.

Le bouton [image] quitte cette fenêtre sans sauvegarder les modifications après avoir répondu au message suivant :

Si OUI la fenêtre se ferme et les changements de prix sont perdus.

Si NON la fenêtre reste ouverte pour continuer le travail.

L'option suivante n'est visible que si la gestion du multitarif est active (cas du mode "pilote) :

Elle permet de choisir le tarif sur lequel faire des calculs :


Etiquettes

Les articles ››

Le menu Articles – Etiquettes affiche la fenêtre suivante (redimensionnable) :

Les étiquettes se génèrent automatiquement lors de la mise à jour des prix sous certaines conditions, en particulier si l’article a du stock (voir en annexe les conditions exactes) ou si des ventes ont été faites sur une période à définir (180 jours par défaut).

Il est possible de ne pas tenir compte du stock.

Evolution à partir de la version 2.426 :

Les étiquettes se génèrent si changement du libellé ou du contenu avec un paramètre pour désactiver ces 2 options (voir paramétrage en fin de paragraphe).

Dans le cas où l'unité = UNITE les informations d'unité (Kg/Litre) et de prix à l'unité ne s'affichent plus sur les étiquettes.

Voici une étiquette avec les informations et une sans :

La fenêtre donne les information du code, de l'ean, du libellé, de la catégorie (normale, promo, prix prévisionnel), du prix de vente.

La création d’un article et la modification d’un prix de vente d’un article existant créent une étiquette.

Il est possible d’ajouter manuellement des articles à la liste en saisissant le code. La touche F2 permet une recherche dans la liste des produits.

Il faut cocher les articles dans la liste et cliquer ensuite sur [image] pour ajouter les étiquettes à la liste.

Le bouton [image] permet d’importer des étiquettes avec le terminal portable.

Le vidage du scanpal dans les étiquettes prends en compte les quantités. Autant de lignes sont créées que de quantité demandée.

Si un article a une quantité à 3, 3 lignes sont générées pour donner 3 étiquettes.

La saisie manuelle est unitaire. Elle peut être faite par le code, l'EAN ou par la recherche dansla liste par F2.

Dans la liste les articles à récupérer doivent être cochés :

Le bouton [image] envoie les articles cochés dans la fenêtre des étiquettes.

Les boutons [image] permettent de sélectionner en plus les articles avec du stock ou au contraire avec un stock nul ou négatif.

La zone catégorie permet de choisir le type de tarif :

La saisie d'articles après la sélection d'une catégorie, génère les étiquettes du type de la catégorie sélectionnée.

La zone de filtrage permet de sélectionner les étiquettes à imprimer :

Le bouton [image] permet de remettre à zéro les filtres.

Le Filtre Désignation est inactif.

Le bouton [image] lance l’impression des étiquettes dont le format dépend du choix suivant [image] .

Le choix Perso donnera une liste de formats d'étiquette personnalisée si besoin. Les fichiers sont de la forme "ETQ_nomdufichier.wde" et seront stockés dans le répertoire [image] défini dans "Paramètres - Configurer documents".

La zone [image] permet de déterminer à quelle position commencer l'impression sur la feuille.

Attention dans le cas d'imprimante laser il faut éviter de réutiliser trop de fois les même feuilles au risque d'avoir des étiquettes qui restent collées dans l'imprimante.

La case à cocher [image] imprime les étiquettes en utilisant le code barre avec le conditionnement de vente (cdtv) supérieur à 1.

Le libellé de l'article est complété par le Pack/x avec x = conditionnement de vente et le prix de vente est = PV x cdtv

Si cette option est décochée, l'étiquette utilise les informations normales de la fiche article avec le code barre dont le cdtv = 1.

Le bouton [image] donne les étiquettes sous forme de listing :

Le bouton [image] enlève l’article surligné de la liste.

Il est possible de faire une multisélection des lignes par la touche CTRL + clic sur la ligne. Dans ce cas les lignes sélectionnées seront effacées ensembles.

Le bouton [image] efface tous les articles de la liste. Cette liste est conservée dans un fichier dans C:\Program Files\LVCLink_F\MemoPurgeEtiquette et sous la forme 2014060611502692.txt.

L’option [image] permet de choisir les articles dont la date d’application est celle saisie.

Le bouton [image] remplit la liste avec les articles correspondant à la date saisie.

Le bouton

Le bouton [image] ferme cette fenêtre en gardant les étiquettes en mémoire.

Les grandes étiquettes sont au format des planches prédécoupées d'étiquettes fournies par LVC :

Les "Petite" existent aussi en planches prédécoupées. Un cadre permet de les découper en cas d'impression sur papier normal :

Les "mini" permette d'être utilisées pour les huiles essentielles par exemples :

Le choix des étiquettes "promos" donne le prix normal barré et le prix en promotion uniquement sur les grandes étiquettes :

Le choix 100 gr donne des prix aux 100 grammes :

Le bouton [image] permet d'ajouter les étiquettes qui correspondent aux articles en promotion dont la période de promo comprend la date du jour ou la date saisie. Il n'est pas possible de saisir une date antérieure à la date du jour.

Le logiciel demande confirmation avec ce message si la date indiquée est égale à la date du jour :

avec ce message si la date est supérieure à la date du jour :

Si l’option “Début Promo” est cochée, le logiciel génère des étiquettes pour les produits dont la date de début de promotion est égale à la date saisie

Le message suivant apparaît pour valider le choix :

Il est possible de saisir dans ce cas une date antérieure, à condition que la promotion soit toujours active.

Génération étiquettes promo avec le terminal portable :

La sélection de la catégorie “promo” :

associée à la lecture du terminal portable :

permet de générer des étiquettes de catégorie 3 - Promo.

Il est aussi possible de saisir des codes articles avec la catégorie "Promo" sélectionnée pour générer des étiquettes de type promo.

Paramétrage Options génération étiquettes :

Le menu

permet de définir l'imprimante pour les étiquettes et les cas de générations des étiquettes :


Export Vers KII

Les articles ››

Le menu

Permet d'exporter la base article vers KeziaII.

L'envoie vers KeziaII des articles active les triggers de gestion des multi-tarif dans KeziaII.

Pour les articles avec l'option PCB Max cochée :

La Qté Appro = PCB

Le PMPA = PA PCB

Le Prix de revient = Prix de revient

Le prix d'achat fournisseur = PA PCB

Sinon

Le réappro mini = Réappro mini

Le PMPA = PA Brut

Le Prix de revient = Prix de revient

Le prix d'achat fournisseur = PA Brut

Le logiciel se base sur l'Idart pour faire le lien entre LvcLink_F et KeziaII.


Contrôle des prix

Les articles ››

Le menu

Permet de comparer les prix du magasin avec ceux du logiciel.

Les prix du magasin sont relevés avec le terminal portable et vider dans la fenêtre suivante :

Les différents boutons permettent d'afficher les articles en fonction des écarts et des prix à contrôler.

Les cases à cocher sur les lignes articles permettent de choisir les articles pour lesquels imprimer des étiquettes [image] ou les lignes à effacer

Le bouton [image] permet d'appliquer les prix relevés à la place des prix des articles dans le logiciel.

Le bouton [image] permet de quitter la fenêtre sans rien faire. Les données de cette table reste malgré tout en mémoire et seront de nouveau présentes lorsque la fenêtre est de nouveau ouverte.

Le bouton [image] vide la fenêtre.


Terminal portable

Les articles ››

Le menu Articles – Export Tarif Scanpal – Base Complète permet d’exporter la base article avec le code, le libellé, le prix de vente, le réappro mini avec le PCB, les ventes des 3 dernières semaines (lues dans KeziaII) et propose le réappro mini ou le PCB (si PCB Max de la fiche article est coché) en quantité pour les commandes.

Après demande de confirmation, le logiciel demande de choisir si les articles en sommeil doivent être exportés (c'est intéressant pour les appareils avec peu de mémoire et dans le cas de nombreux articles).

OUI : envoie les articles en sommeil

Toujours : enverra toujours les articles en sommeil

Non : ne les exporte pas

Jamais : ne les exportera jamais

Le logiciel informe de l'opération a effectuer sur le terminal portable :

Les articles sont ensuite envoyés (fichier c:\program files\LvCLink_F\Scanpaldata.txt) avec les ventes des 3 dernieres semaines calculées au moment de l'envoi.


Prix Bloqués

Les articles ››

Donne une liste des articles dont le prix est bloqué avec la date de fin de blocage, le PVC et les ventes des 3 derniers mois.


Fournisseurs

Les articles ››

Le menu Articles – Liste Fournisseurs affiche la fenêtre suivante :

Elle permet de visualiser, ajouter, modifier et supprimer des fournisseurs.

La saisie création met automatiquement le nom en majuscule.

La modification se fait directement par la liste.


Les Mouvements

Les différentes fenêtres de taille intermédiaire sont modifiables. Le logiciel enregistre la taille définie par l'utilisateur.


Les commandes

Les Mouvements ››

Il existe deux types de commande :

Nouvelle LVC : permet de saisir des commandes pour LVC qui sont envoyées par EDI.

Le choix du type d’article (Epicerie, pain…) sera obligatoire. Il ne sera donc pas possible de mélanger dans une même commande des articles de type différents. La saisie manuelle, par Scanpal et la recherche éliminent automatiquement les articles différents du type de commande.

Le Délai contient par défaut la date du lendemain.

Le Nota permet de saisir des annotations.

Le bouton [image] vide le scanpal dans la commande. Chaque vidage est mémorisé dans un fichier sur le disque.

Un clic droit sur le bouton permet de rechercher un fichier de l’historique des récupérations de Scanpal pour le réinjecter dans la commande.

Les options suivantes permettent de choisir comment récupérer les articles du terminal portable :

Permet en particulier de ne pas récupérer 2 fois un article associé à 2 fournisseur (LVC et 1 externe).

La touche F2 dans les zones de saisie affiche une liste d’article du type de la commande et de choisir les articles à commander en cliquant dans la case de sélection.

Cette liste prend ne prends compte que les articles dont le fournissseur La Vie Claire est le fournisseur principal.

La liste des marques accepte une recherche alphabétique (la frappe d'une lettre positionne sur la ligne qui commence par cette lettre).

Des recherches et sélection sont possibles.

Le bouton [image] permet d'accéder à la fiche article de la ligne sélectionnée (en surbrillance) pour visualisation ou modification.

L'utilisation de ce bouton sur une ligne vide entraine l'affichage d'une nouvelle fiche article dans laquelle le fournisseur de la commande est inclu automatiquement.

La modification de l'article se répercute dans la commande pour :

Le libellé

Le PA

La remise sur PA.

Le bouton [image] bascule les articles sélectionnés dans la commande.

Le bouton [image] ferme la liste sans rien récupérer.

Les articles saisis manuellement se renseignent avec la quantité du « réappro » par défaut. Cette quantité est modifiable mais un contrôle est effectué :

L’alerte est donnée mais la quantité reste celle saisie.

Dans le cas d’une lecture par Scanpal, si les quantités saisies ne correspondent pas à un multiple du « réappro », un message permet de choisir la quantité correcte.

Evolution à partir de la version 2.419 :

A la demande de La Vie Claire, le contrôle des quantités commandées prend en compte le PCB : si la quantité est supérieure au PCB, le contrôle doit se faire sur le PCB et non plus sur le réappro.

Evolution à partir de la version 2.426 :

SI un article est abandonné, une fenêtre l'annonce et affiche le motif de rupture (stocké dans le champ "Motif_Rupture" de la fiche article :

De même si l'article est associé à un article de remplacement, le logiciel propose ce code pour remplacer celui abandonné :

Dans toutes les commandes (en cours au en rappel) la multisélection des lignes est possible pour permettre une suppression plus rapide des lignes.

Le bouton [image] enregistre la commande sans la clôturer. Il sera possible de la reprendre pour la modifier et la valider.

Le bouton [image] enregistre la commande et l’envoie par EDI. Elle ne sera plus modifiable.

Si un article n'a pas de code article associé dans une commande LVC (EAN inconnu), la ligne est ignorée lors de l'export EDI pour éviter des problèmes d'intégration chez LVC.

Un message demande la confirmation de l’envoie :

Et indique la validité de l’envoie :

Un état est proposé à l’impression :

L'envoi se fait en SFTP par le logiciel WinScp qui doit installé et lancé au moins une fois avec les paramètres suivant : adresse : edi.lavieclaire.com, order / order / port 222 et répondre OUI à la question sur l'enregistrement dans le cache de l'identifiant du serveur.

Un fichier log_sftp.txt mémorise le dernier envoi.

Si les 2 lignes de ce type sont présentes, alors l'envoi sur le serveur X3 a réussi :

KEZ_NOR_026916_52.TXT | 0 kB | 1,5 kB/s | binary | 100%

KEZ_NOR_026916_52.TOP | 0 kB | 0,0 kB/s | binary | 100%

Un accusé de réception sera envoyé par LVC dans les minutes suivantes pour confirmer la prise en compte de la commande envoyée.

Le bouton [image] ferme la fenêtre sans enregistrer la commande initiale ou les modifications apportées.

La gestion multifournisseur permet d'associer plusieurs fournisseurs à une fiche article. Le logiciel résonne donc par rapport à cette possibilité lors de la saisie manuelle de l'article, lors de la lecture du scanpal ou de la recherche par F2.

Histo LVC :

Cette option affiche les commandes LVC EDI déjà saisies.

Les dates de début et fin sélectionnent les commandes de la période définie avec le bouton [image] .

Le volet du haut liste les commandes, le volet du bas affiche le détail de la commande sélectionnée.

Dans le détail les colonnes N°Ligne, Code et Désignation sont triable en cliquant sur l'entête de la colonne.

Le bouton [image] rappelle la commande en saisie si elle n’est pas déjà validée ou facturée.

Le bouton [image] renvoie la commande sélectionnée par EDI si elle n’est pas facturée.

Le bouton [image] imprime la commande sélectionnée.

Le bouton [image] génère une étiquette par article de la commande sélectionnée.

Le bouton [image] permet d'accéder à la fiche article de la ligne sélectionnée (en surbrillance) pour visualisation ou modification.

Le bouton [image] génère une copie de la commande sélectionnée.

Le bouton [image] supprime la commande sélectionnée si elle est non facturée.

Le bouton [image] ferme la fenêtre.

Nouvelle externe :

Permet de saisir les commandes qui ne sont pas envoyées par EDI. Cela concerne les fournisseurs autres que LVC mais aussi certaines commandes LVC.

les options [image] permettent de choisir comment récupérer les articles du terminal portable.

Permet en particulier de ne pas récupérer 2 fois un article associé à 2 fournisseur (LVC et 1 externe).

Il est donc nécessaire de sélectionner le fournisseur concerné par la commande.

Le Délai contient par défaut la date du lendemain.

Le Nota permet de saisir des annotations.

Le Franco indique le Franco de port pour ce fournisseur.

Le Téléphone indique le numéro de téléphone du fournisseur si il a été saisi sur la fiche de ce fournisseur.

La saisie et les sélections fonctionnent de manière identique aux commandes LVC.

Le bouton [image] permet d'accéder à la fiche article de la ligne sélectionnée (en surbrillance) pour visualisation ou modification.

La modification de l'article se répercute dans la commande pour :

Le libellé

Le PA

La remise sur PA.

Dans la saisie d'une commande externe, le PA Brut et la remise sont modifiables dans le document mais dans ce cas ces données restent inchangées dans la fiche article.

Le bouton [image] vide le scanpal dans la commande. Chaque vidage est mémorisé dans un fichier sur le disque.

Un clic droit sur le bouton permet de rechercher un fichier de l’historique des récupérations de Scanpal pour le réinjecter dans la commande.

Suivant l'option suivante cochée :

Avec filtre : tri les articles venant du terminal portable. Ne prends que les articles du fournisseur de la commande. Les autres sont ignorés sans alerte.

Sans filtre : les articles inconnus du fournisseur de la commande sont pris en compte avec alerte. Il est possible de supprimer les lignes par la suite.

La touche F2 dans les zones de saisie affiche une liste d’article du type de la commande et de choisir les articles à commander en cliquant dans la case de sélection.

Les articles sont ceux qui appartiennent au fournisseur de la commande qu'il soit principal ou secondaire.

La liste des fournisseurs et des marques acceptent une recherche alphabétique (la frappe d'une lettre positionne sur la ligne qui commence par cette lettre).

Il est malgré tout possible dans la fenêtre de recherche de choisir les articles de tous les fournisseurs afin de pouvoir commander un article normalement non associé au fournisseur de la commande.

Le contrôle de la quantité saisie se fait par rapport au réapprovisionnement correspondant à ce fournisseur.

Un article abandonné sera rejeté.

Par contre il sera accepté si c'est un article LVC (code sans 'X' au début) pour permettre l'achat sur un autre fournisseur.

Cet article apparaît en couleur pour signifier un éventuel problème (il pourrait être en "Abandon" pour tous les fournisseurs).

Le bouton [image] enregistre la commande sans la clôturer. Il sera possible de la reprendre pour la modifier et la valider.

Le bouton [image] enregistre la commande et un document s’affiche. Il peut-être imprimer ou envoyer par mail au format PDF. Elle sera modifiable.

Le bouton [image] ferme la fenêtre sans enregistrer la commande initiale ou les modifications apportées.

Dans le détail de la commande, la colonne "En Cde" indique la quantité déjà commandée. Elle se calcule sur l'ensemble des lignes de commandes par la requête : SELECT SUM(QTE - Q_LIV - Q_ANNUL).

La gestion multifournisseur permet d'associer plusieurs fournisseurs à une fiche article. Le logiciel résonne donc par rapport à cette possibilité lors de la saisie manuelle de l'article, lors de la lecture du scanpal ou de la recherche par F2.

Histo Externe :

Cette option affiche les commandes non EDI déjà saisies.

Les dates de début et fin sélectionnent les commandes de la période définie avec le bouton [image] . Le choix du fournisseur limite les commandes à ce choix.

Le volet du haut liste les commandes, le volet du bas affiche le détail de la commande sélectionnée.

Dans le détail les colonnes N°Ligne, Code et Désignation sont triable en cliquant sur l'entête de la colonne.

Le bouton [image] rappelle la commande en saisie si elle n’est pas déjà facturée.

Le bouton [image] imprime la commande sélectionnée.

Le bouton [image] permet d'accéder à la fiche article de la ligne sélectionnée (en surbrillance) pour visualisation ou modification.

La modification de l'article NE SE REPERCUTE PAS dans la commande

Le bouton [image] génère une étiquette par article de la commande sélectionnée.

Le bouton [image] génère une copie de la commande sélectionnée.

Le bouton [image] supprime la commande sélectionnée si elle est non facturée.

Le bouton [image] transforme la commande en facture (ou livraison).

Le bouton [image] ferme la fenêtre.


Proposition de Commande

Les Mouvements ››

Le logiciel permet de calculer une proposition de commande :

Vous devez choisir le type de commande à préparer :

Pour une proposition d'une commande Vie Claire :

Vous devez choisir le type de commande, le choix par défaut est sur "NORMALE" :

Dans le cas d'une commande normale, il est possible de choisir le Frais, le Sec ou les 2 ensembles.

Un paramètre général, permet de définir la prise en compte des articles non vendus (pour le cas d'une reprise d'article à partir d'un fichier) :

Vous devez ensuite choisir la méthode de calcul :

L'option Conso :

permet de calculer la consommation depuis la dernière commande que le logiciel détermine automatiquement si l'option A est cochée, en manuel si l'option M. est cochée.

Le bouton [image] permet de lancer le calcul.

Il est possible d'ignorer les stock négatifs et / ou de ne pas prendre en compte les commandes fournisseurs en cours (si les quantités sont en négatif, elles seront exclues du calcul dans tous les cas) :

Dans le cas d'un calcul sur la conso en manuel, le logiciel demande de saisir la date de début de consommation à prendre en compte pour le calcul :

Saisir la date sans les "/"

puis la date de fin (la date du jour est présente par défaut) :

La fenêtre contient alors le résultat du calcul :

La colonne Qte contient la quantité à commander. Elle est modifiable. C'est un multiple du réappro.

Les colonnes suivantes sont d'information :

Stock = stock de la fiche article de LvCLink

StockCde = quantité en cours de commande

DispoSite = Stock + StockCde

Q_mini = stock mini

Q_Appro = minimum de réapprovisionnement

Conso = quantité vendue sur la période définie ou depuis la dernière commande d'achat

PCB_Max = si il est coché, le Q_appro correspond au PCB, sinon le Q_appro correspond au Q_appro LVC.

Cette information n'est valable que pour les commandes LVC.

Le bouton [image] permet d'effacer toutes les lignes qui contiennent des quantités de proposition à zéro.

Le bouton [image] peremet d'effacer la ligne sélectionnée.

Le bouton [image] permet d'effacer le calcul (vide la fenêtre) pour permettre un nouveau calcul.

Pour lancer la commande il est nécessaire de sélectionner les articles à prendre en compte

Soit manuellement en cochant chaque ligne soit par :

Le bouton [image] permet de sélectionner tous les articles de la fenêtre.

Le bouton [image] permet de déselectionner tous les articles sélectionnés.

Le bouton [image] permet de valider la proposition.

Il faut confirmer en répondant à la question suivante :

Si Non, le logiciel retourne dans la fenêtre de calcul sans perte d'information.

Si Oui, le logiciel affiche la commande qui sera traité comme habituellement (mémorisaitioni, reprise, ajout ou suppression de ligne, modification de quantité, validation).

Dans le cas ou aucune ligne n'a été validée, le message suivant apparaît :

Ok permet de revenir dans la liste de la proposition pour sélectionner les lignes pour générer la commande.

Le bouton [image] permet de quitter la proposition sans aucune action.

Le bouton [image] permet d'afficher la fiche article (en lecture seule donc sans modification possible) de la ligne surlignée.

L'option [image] permet de faire le calcul sur les fruits et légumes. Il se sera pas possible de générer une commande mais la liste sera imprimable ou exportable pour préparer la commande sur le site web de LVC.

L'option "Mini" :

Permet de lancer le calcul d'après le stock mini renseigné dans la fiche article.

Le logiciel calcule la quantité par la formule : quantité à commander = stock mini - stock disponible arrondi en fonction de la quantité minimale de réapprovisionnement (Q_appro ou PCB) si stock mini positif.

Dans le cas où le stock mini est égal à zéro, le logiciel fait le calcul précédent en considérant que stock mini = 1

La colonne Conso n'est pas présente dans le cas du calcul sur le stock mini (elle n'a pas lieu d'être)

L'option [image] permet de tenir compte de la valeur 0 si elle est cochée, sinon le logiciel ne fera le calcul que sur les articles avec un stock mini positif.

L'option [image] permet d'ignorer les articles en stock négatif. Si l'option n'est pas cochée, le stock négatif sera remplacé par zéro lors du calcul.

Les lignes avec un stock négatif seront visibles en rouge.

Si un article a un Q_Mini = -1, il sera exclu des calculs de réappro.

L'option [image] enchaine le calcul conso + mini directement si elle est cochée.

L'option [image] permet de ne tenir compte que des articles actifs si elle est cochée (dans le cas où peut de ventes ont été réalisé alors que le calcul se base sur le réappro = 0 pour limiter le nombre d'articles)

L'option [image] permet de faire le calcul sur les fruits et légumes. Il se sera pas possible de générer une commande mais la liste sera imprimable ou exportable pour préparer la commande sur le site web de LVC.

Pour une commande externe :,

répondre non à la question :

La fenêtre suivante apparaît :

Il ests nécessaire de choisir un fournisseur avec éventuellement le choix sur un rayon, une famille, sous famille ou fabricant.

Le focntionnement est ensuite le même que pour une commande LVC.

Le bouton [image] permet d'ouvrir une liste des fournisseurs avec la valeur des articles à commander (par rapport au type de calcul choisi) et la valeur du franco (s'il est renseigné dans la fiche fournisseur).

Cela permet de connaître les fournisseurs pour lesquels une commande est possible en respectant le franco.


Les réceptions

Les Mouvements ››

Enregistrement LVC : permet d’importer les fichiers factures envoyées par LVC.

L a fenêtre s'adapte à la taille de l'écran.

La fenêtre affiche la liste des factures déjà enregistrées avec la possibilité de limiter sur une période l’affichage.

Le volet du haut liste les factures, le volet du bas affiche le détail de la facture sélectionnée.

Le bouton [image] importe le contenu du fichier SIH.TXT ou le fichier SIH_XXXXXX.TXT où XXXXXX = code client LVC. Le logiciel fait de lui-même les deux recherches.

Le chemin est précisé dans la zone

Les stocks se mettent à jour.

L’option [image] permet de mettre à jour ou pas le PMPA (qui sert au calcul de la marge) et le dernier prix d'achat de la fiche article dans KeziaII.

L'option [image] activera automatiquement les fruits et légumes et les articles vrac qui se trouve dans la facture.

L'option [image] bloque la mise à jour du PA et de la remise dans la fiche article de LvcLink_F en fonction des informations de la facture. Sinon le PA et la remise sont mis à jour par l'information contenu dans la facture. La remise est enregistrée dans la ligne de facture ainsi que l'ancienne remise et l'ancien prix d'achat.

Le logiciel annonce le nombre de lignes et le montant intégrés :

Dans le cas d'une discordante (problème lors de la lecture du fichier), il est possible de supprimer la facture importée et recommencer l'opération d'intégration.

La fenêtre suivante permet de saisir les éventuelles remises de la facture qui ne se trouveraient pas dans le fichier d'importation :

Les colonnes avec le symbole [image] sont triables.

Les remises peuvent être saisies manuellement ou "automatiquement" si beaucoup de lignes contiennent la même remise :

La remise est entrée dans la zone de saisie et le bouton "Appliquer" lance l'affectation de la valeur à toutes les lignes de la facture. Il est ensuite possible de modifier cette valeur sur quelques lignes si besoin.

La colonne Coeff affiche le coefficient actuel (calculé entre le PV actuel et le PA de la facture), AncPV le prix de vente avant modification (pour les articles en verrou PR/PV) et NouvPV le prix de vente recalculé (pour les articles en verrou PR/PV).

Il est possible de modifier le coéfficient et/ou le Nouv. PV directement sur les lignes de factures. Ce coefficient tient compte de l'option PCB MAx de la fiche article.

L'ancien coefficient (celui de la fiche article avant modification de la remise ou du PA par la facture) et l'ancien PV magasin sont affichés.

Les colonnes PVC (prix conseillé LVC) et petit prix Bio sont présentes pour information.

Il est nécessaire de cliquer sur le bouton [image] pour enregistrer la facture avec ou sans remise ainsi que les modifications manuelles sur les prix de vente. La commande, la livraison et la facture sont générées dans KeziaII.

L'histo stock contient la date de la facture (et non la date du jour) et le numéro de pièce correspond au numéro de commande dans LvcLink_F.

Ce bouton devient actif ainsi que la zone de saisie de la "remise auto" à l'importation, les autres boutons devenant grisés.

Une fois la facture enregistrée ces 2 boutons deviennent grisés et les autres sont de nouveau actifs.

L'enregistrement de la facture crée dans KeziaII, la réception et la facture, met à jout les stocks physique, solde la commande et supprime les reliquats.

Les documents sont datés à la date de facture, l'histo stock est renseigné avec la date du jour.

Le prix d'achat et la remise de la fiche article sont mis à jour. Si l'option PCB MAX est cochée alors c'est le PA PCB qui est mis à jour dans la fiche article.

La ligne de facture contient l'ancien prix d'achat et l'ancienne remise.

En gestion des devises une colonne frais apparait et permet d'affecter les frais de douanes et de transport à chaque article.

Dans ce cas le PMPA de KeziaII = ((PMPA * Stock)+((PA+frais)*Quantité) / Stock + Quantité.

Le bouton [image] permet de vider le terminal portable pour comparer les articles récupérés avec ceux de la facture.

Les anomalies apparaissent dans un fichier imprimable :

Les quantités en positif montre que la réception réelle contient plus d'articles que la facture.

Les quantités en négatif montre que la réception réelle contient moins d'articles que la facture.

Si le code est celui de LVC l'article existe dans la facture.

Si le code est un code barre l'article n'existe pas dans la facture.

Les écarts après vérification seront saisis dans les Avoirs LVC.

Le bouton [image] efface la facture sélectionnée en modifiant le stock en conséquence.

Le bouton [image] permet d'accéder à la fiche article de la ligne sélectionnée (en surbrillance) pour visualisation ou modification.

Le bouton [image] imprime la facture.

Le bouton [image] imprime la liste de(s) factures sélectionnée(s). La multisélectionest possible avec la touche majuscule et le clic sur la ligne.

Le bouton [image] imprime la liste des factures affichées.

Le bouton [image] en bas à droite de la fenêtre permet de générer 1 étiquette par article de la facture.

Le bouton [image] permet de n'exporter que les articles de la facture dans KeziaII. Les PA et PV en particulier seront donc mis à jour uniquement pour ces articles.

Le bouton [image] ferme la fenêtre.

La saisie d'une facture entraîne la mise à jour du PA lié au fournisseur ainsi que le PA BRUT de la fiche article.

Un fichier log mémorise les enregistrements des factures : LogImportFacture.txt

21/10/21 16:10:55 : Intégration fichier : C:\Facture_Lvc\sih.txt

21/10/21 16:15:53 : Enregistrement Facture terminé : FAC1512MON99987

Génération d’une facture d’un fournisseur extérieur :

L a fenêtre s'adapte à la taille de l'écran.

Le bouton [image] de la fenêtre « Commande – Histo Externe » transforme la commande en facture (ou livraison).

La zone [image] permet de saisir, manuellement ou par recherche, le numéro de la facture du fournisseur. Cette zone est obligatoire. Un contrôle est effectué à la validation de la facture.

La zone [image] permet de saisir la date de la facture du fournisseur.

L’option [image] permet de mettre à jour ou pas le PMPA (qui sert au calcul de la marge) et le dernier prix d'achat de la fiche article dans KeziaII.

L'option [image] activera automatiquement les fruits et légumes et les articles vrac qui se trouve dans la facture.

L'option [image] désactive l'alerte liée au fournisseur associé aux articles récupérés par le terminal portable.

L'option [image] permet de ne pas mettre à jour le PA et la remise de la fiche article à partir des informations de la facture.

Le bouton [image] permet de vider le terminal portable pour comparer les articles récupérés avec ceux de la facture.

Les anomalies apparaissent dans un fichier imprimable :

Les quantités en positif montre que la réception réelle contient plus d'articles que la facture.

Les quantités en négatif montre que la réception réelle contient moins d'articles que la facture.

Si le code est celui de LVC l'article existe dans la facture.

Si le code est un code barre l'article n'existe pas dans la facture.

Le bouton [image] apparaît et permet d'appliquer les quantités saisies avec le terminal portable à la place des quantités de la réceptions.

Les quantités apparaissent en bout de ligne dans la colonne "Scanpal".

Dans le cas d'une facture il est conseillé de saisir les corrections dans les Avoirs Externes.

Il est possible de modifier les PA, remise et PV directement dans la facture :

Les colonnes avec le symbole [image] sont triables.

Les zones "PA FAC", "Remise FAC" et PV sont modifiables. La remise est enregistrée dans la ligne de facture.

La modification du PV recalcule le "Coeff".

La modification du "Coeff" recalcule le PV.

La saisie d'un prix à zéro ou d'une remise à 100% ne modifie pas les données d'achat de la fiche article de LvcLink_F et de KeziaII.

Les totaux HT et TTC à la ligne [image] apparaissent en bout de ligne ainsi qu'en bas de la fenêtre pour les totaux généraux (hors port)

Le port avec son taux de TVA peuvent être saisis dans le haut de la facture :

L'escompte peut être saisi dans le haut de la facture :

Les totaux du haut de la facture intègre la valeur du port et de la TVA sur port ainsi que l'escompte :

La zone EAN contient le multicode de l'article.

L'enregistrement de la facture mettra à jour les PA, remise et PV dans la ficher article (penser à faire ensuite un Export vers KeziaII).

La ligne de facture contient l'ancien prix d'achat et l'ancienne remise.

Dans le cas d'une modification de PV les étiquettes seront générées.

Penser aussi à cocher [image] dans la fiche article si la remise est permanente pour éviter son écrasement par la mise à jour LVC des articles.

La zone en pied de fenêtre [image] permet d'appliquer une remise sur toutes les lignes de la facture.

Le bouton [image] en bas à droite de la fenêtre permet de supprimer une ligne de la facture.

Le bouton [image] enregistre la facture et ferme la fenêtre en proposant l’impression d’un document. Le stock est mis à jour. La commande, la réception et la facture sont générées dans KeziaII. Les documents sont datés à la date de facture, l'histo stock est renseigné avec la date du jour. Dans l'histo stock, le numero de pièce est celui de la commande Lvclink_F.

Si la facture est annulée et resaisie, la commande sera générée une deuxième fois sans que le stock soit faussé. Ceci afin d'avoir une trace.

Le bouton [image] permet de n'exporter que les articles de la facture dans KeziaII. Les PA et PV en particulier seront donc mis à jour uniquement pour ces articles.

Le bouton [image] ferme la fenêtre sans enregistrer.

Il est possible d'ajouter des articles en saisissant le code ou l'EAN ou la référence fournisseur ou en recherchant dans une liste d'article accessible par la touche F2.

La saisie d'une facture entraîne la mise à jour du PA lié au fournisseur ainsi que le PA BRUT de la fiche article.

Le bouton [image] permet d'accéder à la fiche article de la ligne sélectionnée (en surbrillance) pour visualisation ou modification.

L'utilisation de ce bouton sur une ligne vide entraine l'affichage d'une nouvelle fiche article dans laquelle le fournisseur de la commande est inclu automatiquement.

Histo Réceptions Externes :

Affiche la liste des factures extérieures déjà saisies :

Le volet en haut liste les factures dont le détail apparaît dans le volet du bas.

La Remise est modifiable.

Une sélection en fonction d’un fournisseur et/ou une période est possible.

L'option [image] permet de sélectionner les commandes non facturées.

Le bouton [image] imprime la facture sélectionnée.

Le bouton [image] efface la facture sélectionnée en modifiant le stock en conséquence.

Le bouton [image] permet de modifier la facture.

Le bouton [image] permet de générer 1 étiquette par article de la facture.

Le bouton [image] donne un état des factures affichées.

Le bouton [image] permet d'accéder à la fiche article de la ligne sélectionnée (en surbrillance) pour visualisation ou modification.

Le bouton [image] permet de n'exporter que les articles de la facture dans KeziaII. Les PA et PV en particulier seront donc mis à jour uniquement pour ces articles.

Le bouton [image] ferme la fenêtre.


Les avoirs

Les Mouvements ››

La séparation entre les avoirs LVC et des autres fournisseurs permet de lister plus facilement les uns par rapport au autres.

Il n’y a pas de différences dans la saisie.

Nouvel Avoir LVC :

Le Motif est obligatoire.

Le numéro de facture sur laquelle porte l’avoir est obligatoire.

Le bouton [image] permet d’afficher la liste des factures et de choisir celle concernée. Il faut alors fermer la fenêtre des factures par le bouton [image] pour récupérer le numéro.

Il faut saisir les codes articles concernés par la demande d’avoir. La quantité est toujours positive. Le logiciel déduira le stock automatiquement. Le PA peut avoir 3 décimales.

Il est obligatoire d’indiquer aussi un motif dans le nota en bout de ligne

Le bouton [image] permet de faire la saisie avec un Scanpal.

Le bouton [image] enregistre l’avoir et propose un document :

Le bouton [image] ferme la fenêtre sans enregistrer.

Histo Avoir LVC :

Le principe est identique aux autres fenêtres d’historique :

Recherche sur une période :

Le bouton [image] imprime l’avoir.

Le bouton [image] donne la liste des avoirs sélectionnés.

Le bouton [image] permet de modifier l’avoir enregistré.

Le bouton [image] permet de supprimer l’avoir sélectionné.

Le bouton [image] ferme la fenêtre.

LA colonne NumAvoirLVC permet de saisir un numéro d'avoir LVC pour savoir que l'avoir a été pris en compte par LVC.

Nouvel Avoir Externe et Histo Avoirs Externes se comportent de manière identique.


Les objectifs

Les Mouvements ››

Cette option permet de définir des objectifs de chiffre d’affaire et de comparer ensuite le CA réalisé au prévisionnel. Il permet aussi de comparer l’année en cours avec l’année précédente.

Création des Objectifs :

Il faut commencer par créer la période de comparaison :

Les dates de début et fin définissent la période à créer par le bouton [image] .

La liste se remplie alors avec les valeurs suivantes :

Date = date des jours de la période à remplir.

Jour = jour de la semaine de chaque date.

Date Histo = jour équivalent (par rapport au jour de la semaine) de l’année précédente.

Ca Histo = CA N-1

Ca Prévisionnel = Ca de référence qu’il est possible de saisir.

Progression = indique le pourcentage de progression à effectuer (% calculer entre le Ca Histo et le Ca prévisionnel).

Commentaire N-1 = commentaire saisie l’année précédente pour expliquer une caractéristique du CA (pluis, neige, grève …).

La zone [image] permet de définir un pourcentage qui va s’appliquer à la liste. Le logiciel calculera le Ca prévisionnel de chaque ligne en ajoutant le pourcentage défini au montant du Ca Histo.

La zone [image] permet d’importer un fichier Excel contenant des valeurs de CA suivant le format suivant :

Le bouton [image] enregistre la saisie.

Le bouton [image] quitte la fenêtre.

Analyse Objectifs :

Permet de vérifier le résultat actuel et de le comparer à l’historique et/ou aux objectifs.

Les dates de début et fin avec le bouton [image] affiche la liste des CA qui donne les informations suivantes :

Date Objectif : date des jours de la période à remplir.

Jour = jour de la semaine de chaque date.

Date Histo = jour équivalent (par rapport au jour de la semaine) de l’année précédente.

Ca Histo = CA N-1

Progression = indique le pourcentage de progression effectuée (% calculer entre le Ca Réel et le Ca Objectif).

Le bouton [image] imprime la liste :

Le bouton [image] ferme la fenêtre.


Les gratuits

Les Mouvements ››

Cette option permet de saisir les gratuités de LVC.

Saisie :

L’option [image] définie la saisie comme un entrée de stock des gratuités.

L’option [image] définie la saisie comme un perte de gratuit.

Le Nota est une zone de saisie libre pour un commentaire.

Le bouton [image] permet de saisir les données avec le terminal portable.

Le choix entre [image] est associé au Scanpal pour déterminer la zone de recherche à utiliser pour les données venant du terminal portable. Par défaut il faut laisser l’option sur Code.

Il est possible de saisir les articles manuellement dans la table par les codes articles ou avec la touche F2 pour afficher une liste d’articles à sélectionner comme dans les autres types de saisie (avoir, commande).

Le bouton [image] en bas à droite de la table de saisie permet d’effacer une ligne.

Le bouton [image] enregistre la saisie à la date indiquée dans la zone [image] et propose un document à imprimer :

Le bouton [image] ferme la fenêtre sans enregistrer.

Histo :

Affiche la liste des saisies de gratuités :

Le volet du haut liste les saisies et le volet du bas donne le détail d’une saisie.

Le bouton [image] permet d’effacer une saisie.

Le bouton [image] permet de revenir dans une saisie pour la modifier et/ou la compléter avec un message d’avertissement :

Le bouton [image] ferme la fenêtre avec un message d’avertissement en cas d’abandon de saisie :

Histo Cumul :

La zone [image] permet de définir la période de recherche et le bouton [image] cumule par article les entrées dans le volet du haut et les sorties dans celui du bas.

Le bouton [image] imprime le cumul des entrées de gratuits valorisé en PA HT :

Le bouton [image] imprime le cumul des sorties de gratuits valorisé en PA HT :

Le bouton [image] ferme la fenêtre.


Les corrections de stock

Les Mouvements ››

Elles permettent de corriger les stocks par des mouvements en entrée ou en sortie.

Entrées :

La zone [image] permet de commenter la correction de stock et est obligatoire.

Le bouton [image] permet de saisir les données avec le terminal portable.

Le choix entre [image] est associé au Scanpal pour déterminer la zone de recherche à utiliser pour les données venant du terminal portable. Par défaut il faut laisser l’option sur Code.

Il est possible de saisir les articles manuellement dans la table par les codes articles ou avec la touche F2 pour afficher une liste d’articles à sélectionner comme dans les autres types de saisie (avoir, commande).

La saisie d’un motif sur chaque ligne est obligatoire.

Le bouton [image] enregistre la saisie à la date indiquée dans la zone [image] et propose un document à imprimer après confirmation.

Le stock est modifié positivement.

Le bouton [image] ferme la fenêtre.

Sorties :

Le principe est identique aux entrées mais avec une diminution de stock au lieu d’une augmentation.

Le bouton [image] ferme la fenêtre.

Histo :

La zone [image] permet de définir la période de recherche et le bouton [image] cumule par article les corrections en entrées ou en sortie en fonction de l’option [image] choisie.

Le bouton [image] imprime le document correspondant à la sélection :

Le bouton [image] ferme la fenêtre.


Outils et paramétres

Copyright © <Octobre 2014> by <François Proteau - JDC SA>. All Rights Reserved.


Outils

Outils et paramétres ››

Import Articles :

Cette option permet l’importation des articles des autres fournisseurs que LVC avec le format Excel défini en annexe. La localisation du fichier est paramétré dans le menu "Paramètres - Configurer Connexion".

Le fichier est au format TXT avec séparateur "|".

Attention : le fichier est supprimé à la fin de l'importation.

Un message de confirmation apparaît à l’importation.

Les articles se créent avec X + LA ZONE CODE du fichier d'importation. Dans le cas de code EAN commun entre un article importé et un article LVC, ce dernier verra son EAN effacé et l'article importé gardera son EAN.

Exemple d'articles LVC acheté à un autre fournisseur.

Attention : le fichier est supprimé à la fin de l'importation.

Un document dans Kwisatz, "Export_LvcLink_F_Articles_Hors_Lvc.001", permettra de générer ce fichier dans le bon format pour les articles hors LVC.

Import Bis :

Cette option permet d’importer un fichier pour ajouter les EAN avec les conditionnements de vente correspondants (bouteille d'eau à 1 et pack à 6)

Son format est :

Code article

EAN

Conditionnement de vente

Le fichier est au format TXT avec le séparateur "|".

Le document "Export_LvcLink_F_Coeff.001" permettra de générer le fichier à intégrer.

Si l'EAN existe déjà l'article n'est pas modifié, s'il n'existe pas il est ajouté.

Import Tarif :

Cette option permet d’importer les prix pour les articles LVC au basculement de Kwisatz à KeziaII afin d’être sûr d’avoir les prix correspondant à l’étiquetage du magasin.

Une fenêtre de recherche du fichier apparaît permettant le choix du fichier texte qui devra avoir le format suivant :

code article LVC

prix de vente TTC

Le fichier est au format TXT avec le séparateur "|".

Le document "Export_LvcLink_F_PV_LVC.001" permettra de générer le fichier du tarif pour les articles LVC.

Import Fournisseurs :

Permet d'importer un fichier Excel pour mettre à jour les informations fournisseurs. Le format est celui de la fenêtre des fournisseurs :

Import Article MultiFou :

Permet d'importer les fournisseurs supplémentaires sur les articles déjà dans la base. Utilise le document "Export_Multi_Fournisseur.001" pour exporter les données suivantes de Kwisatz : code - code interne - code_fournisseur - référence fournisseur - paht brut - taux remise - Réappro mini

Le fichier est au format TXT avec le séparateur = "|"

Lvclink_F se base sur le code de Kwisatz (multicoe de LvcLink_F) pour rechercher l'article exsitant et ajouter les fournisseurs supplémentaires.

Import KWZ :

Import au format Excel avec les informations suivantes :

code article (code LVC ou code interne), EAN (multicode), désignation, code rayon, libellé rayon, code famille, libellé famille, code ligne, libellé ligne, code marque, libellé marque, paht brut, remise, pa ht net, frais taux, frais montant, code tva, taux de tva, pv ttc, code fournisseur, libellé fournisseur, référence fournisseur, unité, coefficient unité, réppro mini, PCB, prix d'achat PCB, abandon (achat interdit, 1ou 0), edi interdit (0), petit prix bio (0), vrac conditionné (0), cross dock (laisser vide), conditionnement vente (lié à l'ean),prix d'achat promo(prendre pa ht net), prix vente promo, date début promo, date fin promo, code comptable achat, code comptable vente, verrou pr-pv, bis, Vente interdite, PV bloqué, Date Fin blocage.

Le champ bis permet d'importer en création (non bis) ou en modification (bis) les articles avec des références fournisseurs identiques.

Si le code est trouvé, les informations se collent sur la fiche existante , sinon un nouvel article est créé en X+code.

Voir annexe.

Import KWZ PARADOX :

importation des articles, rayon,famille, sous-famille, marque, fournisseur par lecture de la base Kwisatz.

Le Répertoire permet de choisir le dossier Kwisatz dans lequel récupérer les données.

Le bouton [image] vérifie les doublons de code interne dans la base article avant l'importation.

La fenêtre "Doublon Fournisseur Article" donne la liste des doublons sur la référence fournisseur.

Le bouton [image] importe des données.

L'option [image] permet de choisir le type de connexion. Paradox pour les version < 3 et Dbisam à partir de la version 3. Dans ce dernier cas le driver ODBC doit être installé et configuré.

LvcLink_F doit contenir les articles LVC sans articles perso ni fournisseur autre que LVC.

La fenêtre "Problème Bis" donne la liste des articles Bis d'eux mêmes.

La fenêtre "DoublonRefFou" donne la liste des articles avec la référence fournisseur identique mais sans être des bis.

Pour les importations à partir d'un fichier Excel, voici quelques précisions :

Le fichier excel ne doit avoir qu'une feuille (l'importation ne se fera qu'à partir de la 1er feuille si le fichier en comprend plusieurs).

Pour les rayons, familles, sous-familles et marque : il faut les codes de ces éléments

Pour le fournisseur : c'est le libellé tel qu'il existe déjà dans LvcLink_F (si c'est le cas), sinon un nouveau fournisseur serait créée.

Pour la TVA : mettre le taux en écrivant 0.2 ou 0.05 sans mettre de format pourcentage

Le conditionnement de vente = 1 dans la plupart des cas, sinon mettre la quantité correcte (6 pour l'EAN d'un pack de 6 bouteilles)

Pour l'unité : KG ou LITRE ou UNITE

Pour le contenu : le poids en kilo ou le volume en litre et 1 pour l'unité.

Au choix de l'option le logiciel demandera si l'export de KeziaII des articles ajoutés devra se faire apès l'importation de LvcLink_F

Import XLS Nouveaux Articles :

Permet d'ajouter uniquement des articles suivant le format suivant :

code article, EAN, désignation, IDray, IDfam, IDssfam, IDfab, Pa HT Brut, Remise, Taux TVA, PV TTC, Fournisseur, Reférence Fournisseur, unité,

Contenu, Q Appro, Cdtv.

Si l'EAN existe déjà, il n'est pas remplacé.

L'import XLS des nouveaux articles génère un code en X+code libre si la zone est vide dans le fichier Excel. Sinon le code du fichier Excel est pris en compte. Le logiciel rajoute le 'X'.

Import XLS Fournisseur_Article :

Permet d'ajouter : Code - code Fournisseur - Référence Fournisseur - PA - Remise - Réappro Mini

Si le code existe tel quel dans Article ajouter dans fournisseur Article

Si le code n'existe pas alors rechercher Xcode, s'il est trouvé alors ajouter dans fournisseur Article

Sinon ignoré la ligne

Import XLS Nouveaux Articles Externes :

Permet d'ajouter uniquement des articles suivant le format suivant :

code article, EAN, désignation, IDray, IDfam, IDssfam, IDfab, Pa HT Brut, Remise, Taux TVA, PV TTC, Fournisseur, Reférence Fournisseur, unité,

Contenu, Q Appro, Cdtv.

Si l'EAN existe déjà, il est remplacé et affecté au nouvel article.

Le code doit être renseigné sans le 'X'.

Import XLS Ajout/Modif :

Permet d'ajouter des articles.

Si l'article existe avec l'EAN, le PA et le PV sont mis à jour, sinon l'article est créé en utilisant le code du fichier excel.

Import EAN / PV TTC (Avec Entete) :

Permet de mettre à jour le PV TTC des articles avec un fichier Excel a 2 colonnes : EAN, PV TTC

L'importation ignore la 1er ligne (suppose qu'il y a des entêtes).

Import depuis une base distante :

La connexion reprend les paramètrage du mode pilote (il ne faut pas l'activer).

Le bouton "Importer les données" lance la connexion au site distant (dont l'accès doit être possible) et récupère les articles en X qui n'existent pas déjà. Donc que des créations et pas de modifications.

Config. touches :

Permet de modifier le tactile en mettant les Idart correspondant aux articles des magasins franchisés à la place des Idart des articles des magasins en propre.

L'association se fait d'après le code interne (code article).

Les fichier articles + touche (de la version V9 des magasins en propre) doivent être copier dans le répertoire c:\temp. Le logiciel met à jour le fichier touche de la BDD KeziaII.

Histo Chgt Prix :

Les colonnes "Date" et "Code" sont triables et permettent une recherche :

Les données sont mémorisées sur une période définie dans le menu PARAMETRES - CONFIGURER CONNEXION.

Par défaut le nombre de jours est de 30.

Lors de chaque modification du prix d'achat ou de vente, l'enregistrement est mémorisé et les plus anciens sont effacés.

La mémorisation des changements de prix des articles ne se fait pas dans le cas d'un calcul des promos dans la fenêtre "Modification prix articles" ni sur les changements dans la fenêtre fruits et légumes pour gagner en rapidité.

Correctif :

Pour voir et éventuellement restaurer des articles effacés (manuellement ou par fusion). La fiche article est recréée dans le fichier article sans le multicode et les informations de l'onglet fournisseur. Il disparait aussi de la fenêtre des archives.

Lors du passage à la version qui suit la 1.6, il faut lancer cette option afin d'alimenter le fichier "Fournisseur_article" à partir des données fournisseurs de la fiche article.

Il faut lancer cette option après la conversion dans la nouvelle version et après avoir relancé Lvclink_F.

importe un fichier Excel au format "code / poids" pour mettre à jour la zone "contenu" de la fiche article.

permet de fusionner deux articles. La fenêtre suivante permet de choisir l'article source à gauche et l'article destination à droite :

Il est aussi possible de faire une fusion par lot à partir d'un fichier excel à 2 colonnes. La 1er contient les articles sources, la 2ème les articles destinations.

La zone "fichier" permet d'aller chercher le fichier Excel, le bouton [image] permet de lancer l'opération.

Dans LvcLink_F l'article destination récupère les informations suivantes :

Le prix de vente, le stock, le(s) multicode(s), le(s) fournisseur(s), la notion de "Sommeil".

L'article source est ensuite effacé. L'article est conservé dans un fichier d'archive. Ce fichier est visualisabe dans le menu OUTILS - CORRECTIF - ARCHIVES. Il est récupérable dans cette fenêtre (sans le multicode et les informations de l'onglet fournisseur).

Dans KeziaII avant exportation des articles par Lvclink_F :

Le stock. L'article source n'est pas effacé mais mis en sommeil et en vente interdite. Si l'article source est sur le clavier tactile il est remplacé par l'article destination.

L'exportation des articles de LvcLink_F vers KeziaII mettra à jour la fiche de l'article destination (prix de vente, multicode et fournisseur).

purge les enregistrements de fournisseur_article qui ne sont liés à aucune fiche article.

recalcule les totaux des factures LVC suite à un bug de la version 2.165

recalcule les quantités livrées et annulées sur les commandes LVC.

Ajout RFS :

Permet d'ajouter des rayon, familles, sous-famille, marque.

Pour les rayons, le fait de cocher l'option "PV Magasin" ajoutera les articles de ce rayon aux articles de la fenêtre "Fruits et légumes"

Pour les familles il faut choisir le rayon associé à la famille créée.

Pour les sous-familles il faut choisir la famille associée à la sous-famille créée.

Histo Chgt Prix :

Donne l'historique des changements de prix d'achat et de vente sur une période définie dans le menu PARAMETRES - CONFIGURER CONNEXIONS :

Changement Classification Article :

Lance un utilitaire (JDC_Exe_LVC_ChangementRFS_MasterLink.exe) qui permet de reclassifier la nomenclature des articles à partir d'un fichier Excel (JDC - Reaffectation nomenclature.xlsx) fourni par LVC.

Fonction suite au changement de classification (rayon, famille, sous-famille) des articles opérée par LVC en janvier 2021.

Suite à cette nouvelle classification, la gestion des types de commandes LVC a été modifié ainsi que la liste des fruits et légumes (rayons 3 et 110) et la fenêtre vrac (famille 53 et rayon 120).

Action Commerciale :

Le bouton [image] lance l’importation des scripts d'action commerciale qui ont été créés sur le serveur au siège de La Vie Claire.

La mise à jour des articles se charge de le faire aussi sans exécution des scripts.

Le bouton [image] lance l'exécution du script sélectionné à condition que la date du jour soit comprise entre la date de début et la date de fin de l’action commerciale choisie.

Il sera nécessaire, à la fin de la période, de lancer le script qui clôturera l’action commerciale choisie.

Le bouton [image] quitte cette fenêtre.


Paramètres

Outils et paramétres ››

Les différents paramétrages se trouvent dans ce menu :

Configurer connexions :

Permet de déterminer les paramètres de connexion aux différentes bases de données.

Chaque magasin aura un login et mot de passe différent pour la connexion à la BDD LVCMaster_F qui se trouve au siège de LVC.

L'option [image] permet de ne pas mettre à jour les TVA existantes lors de la mise à jour des articles. Est utilisée en particulier pour les clients en Corse dont la TVA 1 = 2.10 % au lieu de 5.5 %.

Permet aussi de déterminer le type de mise à jour des articles.

Pour une mise à jour avec respect des tarifs LVC ces options seront cochées :

Ces paramètres sont enregistrés dans le fichier Parametre.fic de la BDD.

Il est possible de récupérer des PV avec une augmentation sur les articles de la marque LVC et/ou sur les autres marques. Ce paramétrages se fait sur LvcMaster_F sur le serveur LVC.

Dans ce cas le PV et le PVC sont mis à jour.

L'option suivante permet de garder le PVC au tarif de base :

Pour une mise à jour sans respect des tarifs LVC les mêmes options seront décochées :

Dans ce cas il est possible d'activer la MAJ automatique des statistiques et stock. Il faut penser à faire la tache qui lance LvcLink_F avant l'heure programmée. Ce paramètre est enregistré dans le fichier Parametre.fic de la BDD.

Dans ce cas la mise à jour sera manuelle pour permettre de vérifier les évolutions de prix d’achat et de décider ou pas le changement des prix de vente.

A cocher ou pas pour agir sur les articles "petits prix bio". Active ou désactive les fonctions "Pas de remise" et "Pas de fidélité" sur tous les "petits prix bio" lors de l'importation des articles LVC.

Cette option permet de décocher les options "Remise interdite" et "Pas de Fidélité" sur les produits qui ne sont plus des PPB en utilisant la requête suivante :

UPDATE ARTICLE

SET NO_FIDEL=0,NO_REMISE=0

WHERE PRIX_BIO=0

AND (NO_FIDEL=1 OR NO_REMISE=1)

AND PAS_MAJ=0

AND PRIX_BLOQUE=0

AND IDFOU='99'

Si coché, alors tous les articles importés auront cette option activée si le PCB est différent de zéro. Dans ce cas le logiciel utilisera le PA PCB pour les calculs.

Configuration de la marque LVC nécessaire pour les mises à jour des prix avec augmentations en fonction de la marque.

Ajout K2 uniquement permet de n'envoyer que les créations d'articles dans KeziaII. Les articles existants ne seront pas mis à jour.

Pas MAJPMPA permet de ne pas mettre à jour le PMPA de la fiche article de KeziaII à partir du PA de la fiche article de LvcLink_F. Sinon le PMPA (qui permet le calcul de la marge) sera mis à jour par le PA ou le PA PCB lors de l'exportation des articles de LvcLink_F vers KeziaII.

détermine le nombre de jours de conservation de l'archive des changements des prix d'achat et de vente. Par défaut la valeur est à 30 jours.

Gestion des promotions :

Permet de rendre les promotions saisies prépondérante par rapport à celles de LVC.

Permet de ne pas importer les promotions LVC.

Permet de décaler la date de fin de promo dans KeziaII d'un jour.

En fait, dans KeziaII, si l'option "Cocci : gestion fidélité Animco" est activée le logiciel ne lit que la date de promo, si elle est décochée, le logiciel lit la date-heure

Gestion des fruits et légumes :

Permet de ne pas importer les PA. Dans ce cas le PA, il faudra cocher la mise à jour des PA à partir des factures d'achats.

Cas des multimagasins avec gestion article sur un site central :

Choisir "Magasin Pilote" et définir les paramètres de connexion. Dans ce cal le LvcLink_F du magasin se connecte au LvcLink_F du site central et non au LvcMaster_F de LVC.

L'option suivante permet d'activer la gestion de plusieurs tarifs :

Il est alors possible d'alimenter plusieurs tarifs en manuel ou en automatique dans la fiche article par l'onglet

et par le menu Modif PV avec le choix

Si l'option "Magasin Pilote" est activée, il est possible de choisir quel tarif alimentera le PV magasin dans les fiches articles :

Dans le mode "pilote", il est possible de ne pas importer les PA des fruits et légumes et au contraire d'importer les remises sur les PA.

Dans le mode "Pilote", il est possible de bloquer l'exportation des réceptions sur le site principal pour ne conserver que la mise à jour des articles :

Export Scanpal :

Afin de gagner de la place dans le terminal portable, dans le cas de base article importante, il est possible d'exclure les articles en Sommeil.

Se modifie aussi en fonction de la réponse à la question posée lors de l'envoie sur le terminal portable.

Envoie des commandes :

Il est possible de remplacer l'envoie des commandes par le batch et Sftp par une gestion SFTP direct :

Il est possible de désactiver la gestion des poids/prix dans la saisie des commandes par l'option :

Si l'option est cochée, on retire la lecture des code barre à poids. Si elle n'est pas cochée, lors de la lecture des codes barres, on lit "ListePrefixePrix","02,22,24,26,28" et "ListePrefixePoids","21,23,25,27,29".

Dans ce cas, les articles en 21.... ont leur contenu initialisé à 1.

Importation des factures :

Des logs sont mémorisés lors de l'importation des factures et la saisie des factures grace à l'option suivante :

Sauvegarde

Le logiciel peut faire une sauvegarde quotidienne (en plus de la sauvegarde par Cobian Backup)

Il faut définir le chemin de la sauvegarde, le nombre d'archive à conserver, l'heure de lancement.

Elle se lancera si l'option "Sauvegarde automatique" est cochée.

Lancement Logiciel :

En fonction de l'option suivante, le logiciel se lance en plein écran ou s'iconise :

Alerte Email :

Il est possible d'activer une alerte mail sur l'importation des articles par l'option

Importation fichiers :

Paramétrage permettant d'importer des données articles à partir du menu d'importation

Fonctions prévues mais pas encore fonctionnelles (nécessite des évolutions côté serveur LVC) :

Connexion à KeziaII V10 :

Configurer l’imprimante :

Permet de définir l’imprimante à utiliser. Sinon utilise l’imprimante par défaut de Windows.

Configurer Etiquette :

Permet de définir l'imprimante étiquette à utiliser. Sinon utilise l'imprimante par défaut de Windows.

Permet de déterminer comment les étiquettes de changement de prix de vente se génèrent :

En fonction du stock par défaut

Indépendamment du stock si cette option est cochée :

En fontion de la présence de ventes sur une période à déterminer (180 jours par défaut) :

Ces 2 dernières options sont incompatibles. Il faut choisir l'une ou l'autre.

Sortir de la fenêtre par la croix.

Choisir Terminal :

Détermine le type de terminal portable puis le port et la vitesse de communication.

L'option "Autre" permet d'accèder éventuellement à d'autre terminaux portables :

Le choix du séparateur permet d'intégrer un fichier txt avec un séparateur différent de la virgule qui est par défaut sur les appareils prédéfinis.

Configurer Douchette :

Permet de paramétrer le port et la vitesse de communication d’une douchette ou scanner connecté sur un port RS232.

Configurer Documents :

L’information du nom, de l’entête et du pied se trouveront sur les documents imprimés par LvcLink_F, en particulier sur les commandes.

Le code adresse doit rester avec la valeur par défaut : A01.

Le site Kezia doit correspondre à celui précisé dans KeziaII.

Le code du client est celui du magasin chez LVC.

Ces 3 éléments sont utilisé dans l’envoie des commandes par EDI.

Entête Documents :

Reprend les éléments de l’entête précédent et permet d’ajouter un logo.

L'option [image] permet d'activer la gestion d'une devise étrangère avec la saisie de la parité dans la zone : . Le taux de change sera utilisé dans la conversion des données résultant de l'importation des articles et des factures.

Modification spéciale Liban :

- Une étoile est ajouté en début du libellé des articles.

- La tva n'est pas importée.

- Les frais de la fiche article ne sont pas écrasés par la mise à jour des articles.

- En facture LVC, une colonne frais permet d'affecter les frais de douanes et de transport à chaque article.

Si Prix Mag alors TOUS les prix de vente sont mis à jour (même les petits prix bio, la librairie, le sans gluten, les prix fixes) et les promotions ne sont pas intégrées.

L'option suivante permet de suivre la mise à jour du paramètre Lvc Auto ou PV Mag malgré l'utilisation des devises

La zone de saisie [image] détermine le chemin pour mettre les etiquettes personnalisable accessible par l'option [image] . Les fichiers sont de la forme "ETQ_nomdufichier.wde".

Réindéxation des fichiers :

Permet de lancer une réindéxation des fichiers dans le cas de soucis sur les index de fichiers.

Normalement cette réindéxation se fait automatiquement au lancement du programme.

Un confirmation est demandée :

Purge EAN orphelins :

Lance l’effacement des multicodes qui ne sont liés à aucun article.

Sauvegarde :

Lance la sauvegarde manuelle de la BDD de LvcLink_F.

Permet son paramétrage.

Cette sauvegarde peut aussi être lancé automatiquement par le paramétrage général :

Archives :

Non fonctionnel actuellement.

Programme Scanpal :

Permet de charger un programme dans le terminal portable.

Outils :

Réservés à la maintenance.

Test Connexion permet de vérifier la liaison avec le serveur LVC.

Recalcul identifiant vérifie et répare les entêtes de fichiers.

Réindex correspond à l’option précédente Réindéxation ds fichiers.

SQL permet de saisir des requêtes de sélection pour agir sur les fichiers.

MAJ Prix Prev. : lance l’actualisation des prix à partir des prix prévisionnels dans le cas où la mise à jour automatique ne se serait pas faite.

Ajout Gencod : permet d’ajouter une liste d’EAN aux articles existants.

Compilation Dynamique : permet d'éxecuter une compilation dynamique

Init N° de Cde : permet de définir le numéro de départ des commandes LVC (suite à une perte de données pour éviter que les commandes envoyées soient rejetées)

Test BAT commande : si paramètre sftp interne alors teste connexion sftp sinon utilise le batch

Config Mail : pour paramétrer l'envoie du mail pour permettre l'envoie d'un rapport de mise à jour des articles

L'envoie par MailJet est conseillé.

Init Rang Fournisseur : recopie le rang du fournisseur depuis KII. Réservé à la maintenance.

Recup Note de KII : recopie le Nota du fournisseur depuis KII. Réservé à la maintenance.

Recup TR de KII : recopie le champ éligibleTR de KII. Réservé à la maintenance.

Purge :

Réservés à la maintenance.

Permet de vider les fichiers des enregistrements dont la date est inférieure ou égale à la « Date limite Purge ».

Il faut prévoir une sauvegarde d’archive avant de lancer cette option.

Le bouton [image] lance la purge sur les fichiers sélectionnés en fonction de la date saisie.

Le bouton [image] ferme la fenêtre.

Consulter Docs purgés :

Permet de consulter les documents archivés par la purge.


Aide

Outils et paramétres ››

A propos :

Donne les informations de licence du logiciel :

Documentation :

Affiche cette documentation sous forme d’aide Windows.

Evolutions :

Affiche la liste des évolutions en fonction des numéro de version.


Annexes

Copyright © <Octobre 2014> by <François Proteau - JDC SA>. All Rights Reserved.


Conditions Génération Etiquettes

Annexes ››

Conditions de génération des étiquettes :

Condition de création d'étiquettes lors de la MAJ prix :

Si

article existe sur LVCLink_f

et a un rayon

et a un stock > 0 sur Kezia

et PV nouveau différent de l'ancien

Si

article existe sur LVCLink_f

et a un rayon

et a un stock > 0 sur Kezia

et PV prev nouveau > 0

et PV prev nouveau différent de l'ancien

Si

article existe sur LVCLink_f

et a un rayon

et n'a pas été trouvé dans HISTO

Si

article n'existe pas sur LVCLink_f

et a un rayon avec PV_MAG à Faux


Structure pour l’importation des articles

Annexes ››

ANNEXE 2 - Structure pour l’importation des articles LvcMaster_F

Zone

Longueur

Type, Valeur, Format

CODE ARTICLE LVC

13

Alpha – Num

CODE EAN13 ARTICLE

13

Numérique

DESIGNATION ARTICLE

40

Alpha – Num

CODE RAYON

6

Numérique

LIBELLE RAYON

6

Alpha – Num

CODE FAMILLE

6

Numérique

LIBELLE FAMILLE

25

Alpha – Num

CODE LIGNE

6

Numérique

LIBELLE LIGNE

25

Alpha – Num

CODE MARQUE

4

Numérique

LIBELLE MARQUE

25

Alpha – Num

PAHTBRUT

8

Numérique

TAUX REMISE

5

Numérique

PAHTNET

8

Numérique

FRAIS TAUX

5

Numérique

FRAIS MONTANT

8

Numérique

CODE TVA

1

Numérique

TAUX TVA

5

Numérique

PVTTC

8

Numérique

CODE FOURNISSEUR

2

"00000099"

LIBELLE FOURNISSEUR

40

Alpha – Num

REFERENCE FOURNISSEUR

13

Alpha – Num

UNITE

10

Alpha – Num

COEFF UNITE

8

Numérique

REAPPRO MINI

4

Numérique

PCB

4

Numérique

PRIX D'ACHAT POUR LE PCB

8

Numérique

ARTICLE ABANDON (ACHAT INTERDIT)

1

Numérique

EDI INTERDIT

1

Numérique

PETIT PRIX BIO

1

Numérique

VRAC CONDITIONNE

1

NUMERIQUE

CROSS DOCK

XX

ALPHA

AJOUT AOUT 2024

ELIGIBLE TR 1 Numérique (1)

MOTIF RUPTURE 250 ALPHA

CODE DE REMPLACEMENT 13 ALPHA

LES LIVRES (RAYON 112) ET LES ARTICLES SANS GLUTEN (FAMILLE 30-76-31) SERONT EXCLUS DES CALCULS DE TARIF PARTICULIER

LES PETITS PRIX BIO, LES LIVRES ET SANS GLUTEN SONT EXCLUS DES REMISES

LES PETITS PRIX BIO SONT EXCLUS DE LA FIDELITE

SI VRAC CONDITIONNE = OUI ALORS METTRE QTTE ASSOCIE AU GENCODE = REAPPRO MINI

LE SEPARATEUR SERA LE SYMBOLE "|"

TOUS LES PRIX SERONT EXPRIMES AVEC DES SEPARATEUR DECIMAUX

LE PRIX D'ACHAT POURRA ETRE A 3 DECIMALES

Si PCB > Réappro Mini alors PCB = La valeur du fichier texte

Sinon PCB = 0


Structure pour l’importation des factures

Annexes ››

ANNEXE 3 - Structure pour l’importation des factures :

1 LIGNE D'ENTETE ET DES LIGNES DE DETAIL
LE SEPARATEUR EST LE PIPE : |
ENTETE |
TYPE DE DOCUMENT | FAA
ENTETE | E
NUMERO COMMANDE ORIGINALE KEZIAII
NUMERO FACTURE X3 |
COE FOURNISSEUR | 99
DATE | JJMMAAAA
SITE | 0
LIB | FAC
N° COMMANDE X3 |
DETAIL |
TYPE DE DOCUMENT | FAA
DETAIL | C
CODE ARTICLE |
REF FOURNISSEUR |
LIBELLE |
QUANTITE |
PA HT |
TAUX DE REMISE |
CODE TVA |
PA TTC | TOUJOURS A ZERO
EXEMPLE |
FAA|E|00507139|FAC1001-CHA3001|99|15012010|0|FAC|
FAA|C|303602|303602|SOIN COUTOUR YEUX ROSE MUSQUEE|3|7.56|0|2|0
FAA|C|303603|303603|CREME DE NUIT ROSE MUSQUEE|3|7.38|0|2|0


Structure export commande en EDI

Annexes ››

ANNEXE 4 - Structure export commande en EDI :

Séparateur = |

Une ligne d’entête et une ou plusieurs ventes

E

Type de commande (voir les type dans le document)

Code client LVC

Adresse Livraison (A01)

Date de la commande

Date de l’expédition = Date de la commande

Numéro de la commande (numéro KeziaII)

Date de livraison

Fournisseur Cross Dock (numéro extrait de la 1er ligne à partir de l’article. Valable pour les commande CD)

L

Code article LVC (Code Interne)

Quantité commandée en décimale.


Structure de l'importation article Excel

Annexes ››

NUMERO | Zone | Longueur | Type, Valeur, Format
1 | CODE ARTICLE LVC | 13 | Alpha – Num
2 | CODE EAN13 ARTICLE | 13 | Numérique
3 | DESIGNATION ARTICLE | 40 | Alpha – Num
4 | CODE RAYON | 6 | Numérique
5 | LIBELLE RAYON | 6 | Alpha – Num
6 | CODE FAMILLE | 6 | Numérique
7 | LIBELLE FAMILLE | 25 | Alpha – Num
8 | CODE LIGNE | 6 | Numérique
9 | LIBELLE LIGNE | 25 | Alpha – Num
10 | CODE MARQUE | 4 | Numérique
11 | LIBELLE MARQUE | 25 | Alpha – Num
12 | PAHTBRUT | 8 | Numérique
13 | TAUX REMISE | 5 | Numérique
14 | PAHTNET | 8 | Numérique
15 | FRAIS TAUX | 5 | Numérique
16 | FRAIS MONTANT | 8 | Numérique
17 | CODE TVA | 1 | Numérique
18 | TAUX TVA | 5 | Numérique
19 | PVTTC | 8 | Numérique
20 | CODE FOURNISSEUR | 2 | NUMERIQUE
21 | LIBELLE FOURNISSEUR | 40 | Alpha – Num
22 | REFERENCE FOURNISSEUR | 13 | Alpha – Num
23 | UNITE | 10 | Alpha – Num
24 | COEFF UNITE | 8 | Numérique
25 | REAPPRO MINI | 4 | Numérique
26 | PCB | 4 | Numérique
27 | PRIX D'ACHAT POUR LE PCB | 8 | Numérique
28 | ARTICLE ABANDON (ACHAT INTERDIT) | 1 | Numérique
29 | EDI INTERDIT | 1 | Numérique
30 | PETIT PRIX BIO | 1 | Numérique
31 | VRAC CONDITIONNE | 1 | NUMERIQUE
32 | CODE FOURNISSEUR CROSS DOCK | 10 | Alpha – Num
33 | CONDITIONNENMENT DE VENTE (POUR EAN) |  | NUMERIQUE
34 | PRIX ACHAT PROMO |  | NUMERIQUE
35 | PRIX VENTE PROMO |  | NUMERIQUE
36 | DATE DEBUT PROMO |  | JJ/MM/AAAA
37 | DATE FIN PROMO |  | JJ/MM/AAAA
38 | CODE COMPTABLE ACHAT |  | ALPHA-NUM
39 | CODE COMPTABLE VENTE |  | ALPHA-NUM
40 | VERROU PR/PV | 1 | NUMERIQUE
41 | BIS | 1 | 0 OU 1
42 | VENTE INTERDITE | 1 | 0 OU 1
42 | PV BLOQUE | 1 | 0 OU 1
 | SI PV BLOQUE ALORS DATE FIN BLOCAGE = 31/12/2025 |  |
 | LES LIVRES (RAYON11) ET LES ARTICLES SANS GLUTEN |  |
 | (FAMILLE 30-76-31) SERONT EXCLUS DES CALCULS DE TARIF PARTICULIER
 | LES PETITS PRIX BIO, LES LIVRES ET SANS GLUTEN SONT EXCLUS DES REMISES
 | LES PETITS PRIX BIO SONT EXCLUS DE LA FIDELITE |  |
 | SI VRAC CONDITIONNE = OUI ALORS METTRE QTTE ASSOCIE AU GENCODE = REAPPRO MINI
 | LE SEPARATEUR SERA LE SYMBOLE "|" |  |
 | TOUS LES PRIX SERONT EXPRIMES AVEC DES SEPARATEUR DECIMAUX
 | LE PRIX D'ACHAT POURRA ETRE A 3 DECIMALES |  |
 | ATTENTION AU FOURNISSEUR DONT LE CODE EST NUMERIQUE DANS LVCLINK_F
 | ET ALPHA NUMERIQUE DANS KWISATZ. FAIRE DES CORRESPONDANCES POUR
 | LES CODES AVEC DES LETTRES. |  |


Structure Ajout Article

Annexes ››

Le choix [image] permet d''ajouter des articles à partir d'un fichier excel dont la structure est la suivante :

sCode est chaîne = xlsDonnée(nIdFic,i,1,Faux)//1

sEAN est chaîne = xlsDonnée(nIdFic,i,2,Faux)//2

sDesignation est chaîne = xlsDonnée(nIdFic,i,3,Faux)//3

sIDRAY est chaîne = xlsDonnée(nIdFic,i,4,Faux)//4

sIDFAM est chaîne = xlsDonnée(nIdFic,i,5,Faux)//5

sIDSSFAM est chaîne = xlsDonnée(nIdFic,i,6,Faux)//6

sIDFAB est chaîne = xlsDonnée(nIdFic,i,7,Faux)//7

sPAHT_BRUT est chaîne = Remplace(xlsDonnée(nIdFic,i,8,Faux),",",".")//8

sTauxRemise est chaîne = Remplace(xlsDonnée(nIdFic,i,9,Faux),",",".")//9

sTaux_TVA est chaîne = Remplace(xlsDonnée(nIdFic,i,10,Faux),",",".")//10

sPV_TTC est chaîne = Remplace(xlsDonnée(nIdFic,i,11,Faux),",",".")//11

sFournisseur est chaîne = xlsDonnée(nIdFic,i,13,Faux)//13

sRef_Fou est chaîne = xlsDonnée(nIdFic,i,14,Faux)//14

sUnite est chaîne = Remplace(xlsDonnée(nIdFic,i,15,Faux),",",".")//15

sContenu est chaîne = Remplace(xlsDonnée(nIdFic,i,16,Faux),",",".")//16

sQ_APPRO est chaîne = Remplace(xlsDonnée(nIdFic,i,17,Faux),",",".")//17

sCDTV_Vente est une chaîne = Remplace(xlsDonnée(nIdFic,i,18,Faux),",",".")//18

Le code article est préfixé automatiquement par le X.

Si le nom du fournisseur n'existe pas, il est créé.

Le CDTV est renseigné à 1 par défaut.


Règles importation KWZ

Annexes ››